Snowmobile Fanatics banner

1 - 13 of 13 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter · #1 ·
it idles fine but when i get to about 6 grand it pops and backfires. i cleaned the carbs, changed the fuel, fuel filter, plugs and checked the spark. compression is 162 on each side. cant seem to figure it out.
 

·
Registered
Joined
·
9,987 Posts
Is the backfire out the carbs or exhaust?

Is it jetted right for this temperature?
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #3 ·
Ugly_old_Poo_kid said:
Is the backfire out the carbs or exhaust?

Is it jetted right for this temperature?
yeah. it has 490's for jets. it takes 500 stock. its backfireing out the intake
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #5 ·
Ugly_old_Poo_kid said:
Sounds like your reeds are shot.
there brand new. its a really wierd pop it makes. i even brought it to the dealer and they couldnt figure it out. they tryed about everything they even checked the top end which is brand new. they said they went throught the whole thing.
 

·
Registered
Joined
·
718 Posts
could the timing be off?
 

·
Registered
Joined
·
8,842 Posts
never heard of a polaris loosing a flywheel key.

a pop out the exhaust usually means lean, like you have to lift the needles one clip.
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #9 ·
i got it! it was the keyway. sure enough i took it off and it was broke. it broke the flywheel too though...
 

·
Registered
Joined
·
622 Posts
Your lucky the flywheel did not let loose on you those things can go off like a hand grenade!!
 

·
Registered
Joined
·
590 Posts
At least you found out before winter came.
 

·
Registered
Joined
·
9,987 Posts
^^ - no kidding!!!

Nice to find that ahead of winter, and shame on the dealer for not finding that!!
 
1 - 13 of 13 Posts
Top