Snowmobile Fanatics banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,427 Posts
Discussion Starter #1
OK well i sunk my snowmobile and i got the engine running again but the EGT gauge isn't working so i was going to buy a new probe maybe a new gauge. Is there any way that i could get it working again.
And my speedo and rpm gauge have evaporated after in them how do i get the water out?
 

·
Registered
Joined
·
8,108 Posts
The probes are probably OK, but the gauge may have water damage. I would send it back to the manufacturer, it will probably be cheaper than buying a new one if they can fix it.
 

·
Registered
Joined
·
42 Posts
Originally posted by Clouse2411
[br]OK well i sunk my snowmobile and i got the engine running again but the EGT gauge isn't working so i was going to buy a new probe maybe a new gauge. Is there any way that i could get it working again.
And my speedo and rpm gauge have evaporated after in them how do i get the water out?
If your gauge is a Digatron unit... Our Tech guys can bring it back to life for you.Visit http://www.digatronusa.com/repair.shtml for repair procedures. Most repairs cost less than $75. If it does cost more they will call you for approval.
 

·
Registered
Joined
·
1,427 Posts
Discussion Starter #4
this is my gauge
[galleryattach=12467]
the middle one
 

·
Registered
Joined
·
42 Posts
Originally posted by Clouse2411
[br]this is my gauge
[galleryattach=12467]
the middle one
Sorry I cannot help you with it. Whish I could.
 
1 - 5 of 5 Posts
Top