Snowmobile Fanatics banner
1 - 13 of 13 Posts

· Registered
Joined
·
537 Posts
Discussion Starter · #1 ·
I was riding with my dad today and he blew up his 2005 edge 800 for the second time. The first time he snapped the crank just inside the case at 2000 miles. We had it sent out to indy dan and had the cased machined, new crank and wide bearing kit. 300 miles later (this morning) he snapped the crank just outside the case. He isnt going to put another 800 back in. He needs reverse, though. He would like to keep the PERC, but I dont know what motors will work with the 800 electronics. I dont believe any will. People have had better luck with the 700's so he will consider that. But if it doesnt already have the reverse oil pump we will need to find that. So im open for suggestions as to the best motor to drop in there.
 

· Registered
Joined
·
2,433 Posts
Doesnt Indy Dan warranty his work?I am sure he could get it fixed thru Indy.I would also have the primary clutched rebuilt and balanced,real important on the 700 and 800's.
 

· Registered
Joined
·
537 Posts
Discussion Starter · #3 ·
From what I could tell, the oil pump failed. The crank was blue and extremely hot and there were many air bubbles in the oil line going to the pto bearing. The crank sheared off almost flush with the primary clutch. It destroyed the primary and left huge gouges in the sheaves of the team roller secondary. Not indy dans fault.
 

· Registered
Joined
·
2,433 Posts
That sucks....did he bleed the oil line?
 

· Registered
Joined
·
9,987 Posts
Ask indy dan what he would do...
 

· Registered
Joined
·
2,124 Posts
Indy Dan is a pretty much straight up guy, he works out of his residence now in Welch. Sounds like you have a mechanical failure in the oil pump versus the crank? I know the 800 cranks are prone to failure, my buddy is dealing with a '04 SB with a blown crank at the moment, Polaris really should step up to the plate on this issue
 

· Registered
Joined
·
370 Posts
Did he mix the first tank of gas with oil, that's probably what made the sled go 3XX miles. Happened to my buddy on his rev 600. The second time the motor went he took off the oil injection pump and there was a catch in it when you pull the lever on the pump it was about half way through the pull. If he got a new pump he would prob be ok if he rebuild it again, my buddies rev has over 800 on the rebuild. But, it might be cheaper to get a new motor.
 

· Registered
Joined
·
537 Posts
Discussion Starter · #13 ·
polaris1man said:
barney said:
Here is some pics:

I would like to see the PTO bearing on the crank
I havent gotten it down that far yet... Its screwed though. I pulled the motor and top end for my dad tonight. Cylinders were dry. It was starving for oil. My dad had a mechanic (who obviosly didnt know what he was doing) bleed the oil pump. I cant beleive it made it 330 miles. Indy dan said that that the touque specs on the 04-05 800's were way to tight. That caused the bearing to run hot. Then with the lack of oil the bearing seized for a millisecond and snapped the crank. Thats what indy dan said and he know his stuff so I will listen.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top