Snowmobile Fanatics banner
1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Problem is engine temp lamp comes on, engine overheats. Worse at slow speeds 2up or with skiboose hooked on. Engine sems to rev too high, clutch engages at about 4200 rpm, in tight trail revs about 5500 rpm. Is this normal rpm? Engine is not running lean, maybe slightly rich. All three heat exchanger are roughly the same temp. I am not running with studs.
[red]Moved to The Shop by Polaris-Man[/red]
 

·
Registered
Joined
·
1,509 Posts
hey if its a polaris and the motor overheats it will start to rev. high and it will seem really funny but thats normal they program it to do that so it wont burn down. just drive in snow or shut her down to get her cooled down
 

·
Administrator
1998 XCR 440
Joined
·
12,832 Posts
<BLOCKQUOTE id=quote><font size=1 face="Verdana, Arial, Helvetica" id=quote>quote:<hr height=1 noshade id=quote>Originally posted by XCSP 700GUY:

hey if its a polaris and the motor overheats it will start to rev. high and it will seem really funny but thats normal they program it to do that so it wont burn down. just drive in snow or shut her down to get her cooled down

[/quote]


This sounds weird to me...



http://www.bolliger-mabillard.com

I Love B&M Coasters.
 

·
Administrator
1998 XCR 440
Joined
·
12,832 Posts
could be true. It still strikes me as odd though.

I figure an overheating engine would shut off. Last year when my temp light came on, well, the light came on. I hit the kill switch. but my machine was leaking anti freeze, so I knew why it came on.



http://www.bolliger-mabillard.com

I Love B&M Coasters.
 

·
Administrator
1998 XCR 440
Joined
·
12,832 Posts
That's what I figured..



http://www.bolliger-mabillard.com

I Love B&M Coasters.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top