Snowmobile Fanatics banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Engine always starts easily and runs fine for awhile then dies. This happens at different speeds, can occur after 20 minutes or over an hour into a run. Always starts fine right after it dies, then it may run fine for two minutes or another half hour. This problem started this year the first time out.Changed the gas and plugs and ran some seafoam through the gas. Noticed that all the electric components stay alive until the engine winds down to stop, so it doesn't seem to be a large scale electrical failure.
Anyone have any suggestions?
 

·
Registered
Joined
·
622 Posts
air(maybe even ice if cold enough) in fuel line/fuel rail, fuel pump faulting out, faulty injector, and coil could be breaking down(getting hot). This is where i would start looking.
 

·
Registered
Joined
·
1,264 Posts
900sledr said:
Engine always starts easily and runs fine for awhile then dies. This happens at different speeds, can occur after 20 minutes or over an hour into a run. Always starts fine right after it dies, then it may run fine for two minutes or another half hour. This problem started this year the first time out.Changed the gas and plugs and ran some seafoam through the gas. Noticed that all the electric components stay alive until the engine winds down to stop, so it doesn't seem to be a large scale electrical failure.
[highlight=yellow]Anyone have any suggestions[/highlight=yellow]?
Yeah...Don't buy another fusion[thumb]. Polaris quit making them for a reason.
 
1 - 3 of 3 Posts
Top