Snowmobile Fanatics banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi !
i have a widetrack from 1990 with 488 Engine and 2 carbs.

i changed the crankshaft and pistons on it last Winter , but i cant get it too run smoothly, the Engine vibrates when i push the throttle .
anyone who has any ide what it can bee ?

i tried too sync the carbs with no success .

greetings Mikael
 

·
Registered
Joined
·
2,571 Posts
Welcome. This could be a number of things. I would start with a wellness check of the engine. Do a compression test. How does the engine run other than the vibration? Have you verified good spark on both cylinders? Maybe change spark plug caps as cheap insurance?

Was the clutch removed/disassembled during the engine work? Clutches are balanced and need to go back together the way they were from the factory or be rebalanced. This could cause vibes and also damage bearings/seals on the pto side.

A bad engine mount can cause vibes. Verify all mounts are in good condition and tight. Verify that the torque stop is set correctly. This is a small adjustable stop, usually in the area behind the primary clutch and keeps the engine from torquing/twisting too much. There is a spec but usually just get clutches aligned and all mounts torqued and run this up so it just touches the engine block and tighten the lock nut.

Good luck, keep us posted.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Hi again!
The clutch is removed from the engine.
On high revs is sounds pretty good but when it revs down i vibrates again, can it have anything with the ignition timing that makes it vibrates.
 
1 - 3 of 3 Posts
Top