Snowmobile Fanatics banner

1 - 10 of 10 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
i just bought a 96 xcr 600. it has the xtra-10 rear suspension.

but i cant figure out why it sits so low to the ground???

the shocks are good...springs are good...

does antone have any ideas... or have a schematic on this

suspension i could use to figure out if its put together the wrong

way ??? ??? ??? ??? ??? ??? ???
 

·
Registered
Joined
·
78 Posts
Discussion Starter #3
no pic...

it does act right

no the shocks arnt down ...

it looks as if a 500lb guy is sitting on it ??? but still works good?
 

·
Registered
Joined
·
78 Posts
Discussion Starter #5
yea... its right next to my 94 xlt and its sittin like 2-3 inches lower and the xlt only has 8 inches...
 

·
Registered
Joined
·
225 Posts
I am curious..I have the ame sled and always thought it should sit a little higher than it does. I was enven tthinking of putting a drop bracket on.
 

·
Registered
Joined
·
317 Posts
the x 10 dont sit that hi as is. i swaped one into my '92 xcr and there was not too much of a diff. good luck with that 600 the like to go boom.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #8
NO..NO.. it already had a blown motor when i bought it ...

i put a 580 triple motor in it yesterday runs great

[:)][:)][:)][:)][:)][:)][:)][:)][:)][:)][:)][:)][:)]
 

·
Registered
Joined
·
5,686 Posts
You have a problem, not sure what it is without pics, but my Xtra-10 sits a few inches higher than the 8" suspension on my Xlt.
 

·
Registered
Joined
·
192 Posts
http://www.polarisfiles.com/forum/index.php?&act=products&mode=snowmobile&year=1996&id=290


http://216.37.204.206/ingles/polaris_oem/PolarisSnow.asp?Type=13&A=149&B=29
 
1 - 10 of 10 Posts
Top