Snowmobile Fanatics banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2,020 Posts
Discussion Starter · #1 ·
Well here in Northern Connecticut we have finally gotten our first real snowfall of the year. We now have around 3-4" of heavy heavy wet snow with absolutely no base and a halfway frozen ground underneath. I'm thinking of gassing up the Fusion for the FIRST time since August and taking her out for a few little rips acorss the yard tomorrow, I'm PUMPED! That "few" laps around the yard will probobly turn into hours of fun and entertainment because I have about 15 acres worth of small trails and small opening to mess around in, maybe I'll get her broken in tomorrow!
 

·
Registered
Joined
·
102 Posts
Wow! We had a bad winter where i'm at... we didn't get good snow untill like dec 20. If we didn't get snow untill now I would of choked someone....

Have fun!!!
 

·
Registered
Joined
·
2,020 Posts
Discussion Starter · #4 ·
Well guys, I've officially been on the maiden voyage. I put about a mile and a half on her and I'm stoked! The dealership I bought it at put a lot of oil into the tank for break-in, and even though I filled the tank to thin it out it seems as though there is still too much. It backfired once when she first started and runs very poorly at around 4000-5500 rpms but after you hit around 2/3 throttle she opens up and RIPS! I'm trying not to give her too much due to lack of snow and she's new so that was a bit unexpected, went right down to dirt for that 5-7 feet haha! I almost went up to the St. Johnsbury, Vermont area last weekend, but I couldn't get a trailer to haul my sled.
 
1 - 4 of 4 Posts
Top