Snowmobile Fanatics banner

1 - 11 of 11 Posts

·
Registered
Joined
·
15,722 Posts
Discussion Starter #1
Are there any here....
 

·
Registered
Joined
·
15,722 Posts
Discussion Starter #3
I talked to a guy over at hcs, He fiqures that the alt does not switch on and off fast enough, that why I am getting the battery light to flash on and guage to quiver. It is putting out 14.8-15.8v all the time. Is alright when running down the road but at stop signs it looks like I am a cop with the lights lightly flashing.
 

·
Registered
Joined
·
2,518 Posts
Did you go over to www.ford-trucks.com and see what you could find there? I know theres a lot of boneheads who post on that site, but there is a vast wealth of knowledge there and somewhere Id bet there is an answer to your problem.
Considering its the 2nd alternator you have tried, I cant believe its something wrong with the alternator. Its gotta be some stupid little thing that regulates the electricity thats messing it up.
I obviously dont have the answer, but it just seems like too much of a coincidence that 2 different alternators did the same thing.
 

·
Registered
Joined
·
2,518 Posts
I made a thread on FTE about it, heres the link: http://www.ford-trucks.com/forums/559045-headlights-and-dome-light-have-slight-flicker-at-idle.html#post4228188
Not sure if they will have an answer for you, but I think its your best bet.
 

·
Super Moderator
Joined
·
11,272 Posts
ford-trucks.com is a awesome site. I have gotten lots of useful information off of there.
 

·
Registered
Joined
·
2,518 Posts
Yup, Ive gone there before when I had issues with my F-150 and the were really helpfull.
We have one answer already, one guy thinks its the voltage regulator.
 

·
Registered
Joined
·
15,722 Posts
Discussion Starter #8
Only problem is the voltage regulator is internal on the alternator. So I need another one or get a voltage regulator, which is special order.
 

·
Registered
Joined
·
15,722 Posts
Discussion Starter #9
Got it fixed, bought a ford alt at $300 and have no more isues. I will never buy another auto zone electrical part ever again.
 

·
Super Moderator
Joined
·
11,654 Posts
Glad to hear you got the bug worked out. And I too have found FTE quite helpful at times.
 

·
Registered
Joined
·
15,722 Posts
Discussion Starter #11
Sad part is I got more help from fxdwg over at hcs. He is a ford tech.
 
1 - 11 of 11 Posts
Top