Snowmobile Fanatics banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I picked up this sled and cant get to run right

Runs like a Raped Ape for 2 or 3 mins and then boggs like a biotch .. If i even touch the throttle in dies... Sometimes seems to run a bit hot now..

Tank was empty and brand new fuel was used..I have cleaned the Carbs over and over ... Runs great for a few mins (just enough to get me bonner) then Bogg city again

Replaced Fuel lines, Checked compression, New Plugs ect ect

Plugs look fat at first now brown.. I dont think its lean.. Most lean conditions ive dealt with the motor still runs

Am I missing where a vacume line might be or something ??????

Guy i bought the sled from claims ran great last year ! Had dry rot on some lines however i did replace ones i could find that looked bad..

Running out of ideas or possible problems
 

·
Registered
Joined
·
2,718 Posts
I am no pro at this, but are you at the same sea level of the previous owner? Could it be a jetting issue? My 98 FZ 670 was a screamer too! When it was real cold out, that thing pulled hard!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Taking other angles today ... I drained the fuel and now found some H20.. Gee imagine that... Problem is every time you dig deeper you run the risk of breaking things... Putting the pick up back together the grommet for the fuel tank split in half...So im off to the ski-doo parts dealer who employees morons behind the counter and never has anything in stock

Assuming the little bit of water I found is the issue I should be good but ya never know .. Should have used ISO HEET but like a dumba$$ I didnt.. my bad..

Same altitude as the other owner .. The jetting is good .
 

·
Registered
Joined
·
4,755 Posts
some times might have to put a small inline filter from the fuel pump to each carb ,I have had to do this on many sleds and works great
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
All fixed !!!!!!

Bad Gas from a local pump....

Drained the tank and used fuel from another station and problem solved...
 
1 - 5 of 5 Posts
Top