Snowmobile Fanatics banner
1 - 9 of 9 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Had a Ultimax 3 that blew the other day...million pieces...dropped a new Ultimax XS in, was good at start but after warmed up get a mean squel at idle. Took it out for about 8 miles to break the belt in, put of the lift when I got home and the squel stopped, touched the brake and the squel was back. Any ideas, or will this work itself out?
Thanks
 

· Registered
Joined
·
455 Posts
Did you adj. the belt deflection, when you installed the new belt? You also need to adj. it as the belt is wearing. To get the best performance/belt life.

I see they are two different belts. Are they the same length, and width?
 

· Registered
Joined
·
196 Posts
2L8ULuz said:
Did you adj. the belt deflection, when you installed the new belt? You also need to adj. it as the belt is wearing. To get the best performance/belt life.

I see they are two different belts. Are they the same length, and width?
The belt is wrong for the machine. Either too wide or short
 

· Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
It is the right belt according to the cross reference charts from Ultimax, the XS is just a new construction belt for higher horsepower engines. I did not check the deflection on the new belt, had never done that before. I'll check that and see how that works.

Thanks for the help.
 

· Registered
Joined
·
196 Posts
drafoss said:
It is the right belt according to the cross reference charts from Ultimax, the XS is just a new construction belt for higher horsepower engines. I did not check the deflection on the new belt, had never done that before. I'll check that and see how that works.

Thanks for the help.
Unless your machine has monster HP the stock belt will suffice. Stop wasting money on names for belts
 

· Registered
Joined
·
319 Posts
Speedfreak1 said:
2L8ULuz said:
Did you adj. the belt deflection, when you installed the new belt? You also need to adj. it as the belt is wearing. To get the best performance/belt life.

I see they are two different belts. Are they the same length, and width?
The belt is wrong for the machine. Either too wide or short
wrong. the xs is fine. i have one on my dragon 600. check the belt tension. it's too tight for sure.
 

· Registered
Joined
·
1,405 Posts
Speedfreak1 said:
drafoss said:
It is the right belt according to the cross reference charts from Ultimax, the XS is just a new construction belt for higher horsepower engines. I did not check the deflection on the new belt, had never done that before. I'll check that and see how that works.

Thanks for the help.
Unless your machine has monster HP the stock belt will suffice. Stop wasting money on names for belts
fusion 900..... need say more? all the fusion sleds are natorious for blowing belts... nature of that beast.....
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top