Snowmobile Fanatics banner

Status
Not open for further replies.
1 - 20 of 47 Posts

·
Registered
Joined
·
269 Posts
Discussion Starter #1
Well On Sunday I had to call crazy cooter to come with the hook to pick up the General! She was running great we gone about 40 miles and for some reason the pto side piston decided to explode busting the rod and pushing it through the case.I am not sure why this happened, I tore the motor down and the piston has a perfect wash and the plugs have never been better a nice card board brown.So it didn't lean out ,the rings aren't bent and the cylinder is fine no signs of a seize up.The rod however came up and took a big chunk out of the sleeve so that is no good. So my $300 pistons and $600 crank lasted all of about 300 miles this year!I am waiting to see what the shop is going to do for me.He can't explain why this happened.I asked him if it is possible that it was a poor piston cast and it eventually just blew apart???? The other two pistons have chips in the bottom of the skirt like they were catching on something.The recoil side has a hair line crack in it to. I have another crank case and he has a top end .We are not sure what kind of shape the crank is in now so I am waiting to hear on that.What do you guys think should happen in this case? I need 3 pistons a rod and bearing.If he isn't going to help me out I will be selling the sled as a rolling chasis as it sits in these pictures.[galleryattach=12422]

[attachment=47089]
 

Attachments

·
Registered
Joined
·
5,400 Posts
You went to aftermarket pistons and I hope you checked the clearance for the skirts before running it for an extended time.
 

·
Registered
Joined
·
269 Posts
Discussion Starter #3
I didn't do the rebuild I took it to a shop the guy has worked on polaris for 28 years. I would asume that he checked all that .
 

·
Registered
Joined
·
5,400 Posts
Hmmmm.
 

·
Registered
Joined
·
276 Posts
Like triple650indy indy said if the clearance was wrong it could cause the piston to slap the cylinder walls. If all of them are chipping i would look at that first.
 

·
Registered
Joined
·
3,063 Posts
post pics. For a rod breaking that'll happen. If it was ever hydraulic locked that'll stress it which could eventually cause it to break.
 

·
Registered
Joined
·
2,973 Posts
Sounds like the rod bearings to me.
 

·
Registered
Joined
·
5,686 Posts
that just plain sucks!!

This would be the 3rd time in a year that this motor blew on you, correct??

The shop you are taking it to isn't doing the rebuild correctly. 28 years or not, he is missing something or not taking the time to spec everything out.

I would tell him that you want him to pay for you to go to another shop and have them do it.
 

·
Registered
Joined
·
5,686 Posts
that just plain sucks!!

This would be the 3rd time in a year that this motor blew on you, correct??

The shop you are taking it to isn't doing the rebuild correctly. 28 years or not, he is missing something or not taking the time to spec everything out.

I would tell him that you want him to pay for you to go to another shop and have them do it.
 

·
Registered
Joined
·
269 Posts
Discussion Starter #13
The bottom end is at the shop if I get it back I will post pictures. I have no idea what would cause this to happen. When do you say enough is enough? $1000 dollars each winter is getting expensive.. Wife not happy !lol. The best explanation I have heard is the crank case got tweaked a bit the last time a bearing went and was not lined up properly leaving something for the pistons to catch on.Looking for a new motor might be the only option . I have put to much work into the old girl and it was right where I wanted it to be before it blew.He can't explain what caused it to happen. I have a black line on my oil tank that I always fill to and it was down from the line quite a bit in 40 miles,he said if anything it was running a little rich. It is a waiting game now I guess.
 

·
Registered
Joined
·
269 Posts
Discussion Starter #15
Never been hydro locked. This is a brand new motor with 280 miles on it. 2 good 100 mile trips and 2 short 40 mile trips.
 

·
Registered
Joined
·
1,165 Posts
nice sled
 

·
Registered
Joined
·
4,755 Posts
if you have the stock air box on it ,maybe mud dobbers got in it and built a nest?? that has happen before ,then as you ride the dirt falls off turns to mud cause of the moisture and the engine inhales it[V]
 

·
Registered
Joined
·
269 Posts
Discussion Starter #18
What is a mud dobber ? Lol. nothing in the air box clean as a whip and the circlips were on the wrist pin. Piston slap sounds like a good one...But if the clearence was off wouldn't there be signs of blow by on the piston?
 

·
Registered
Joined
·
1,230 Posts
what shop did you take it too?
 
1 - 20 of 47 Posts
Status
Not open for further replies.
Top