Snowmobile Fanatics banner

1 - 10 of 10 Posts

·
Registered
Joined
·
321 Posts
Discussion Starter #1
Just back from a sweet ride in the snowies.The only thing that sucks is that my sled quit running.The king cat started to drop a cyclinder when i was in a climb and i came back down it kept cutting out so i started to head back to the truck and got a mile from the truck it completely quit running[V].had to get towed the rest of the way.my first cat and it kraps out on me.I guess sh*# happens[:D].i only got a couple of pics. my helmet cam quit workin also[:(!]so i don't have any vid. of this trip but in a couple of weeks i going back out and will get some more pics. and vid.
[attachment=50844]
[attachment=50845]
[attachment=50846]
[attachment=50847]
 

Attachments

·
Registered
Joined
·
2,477 Posts
wow that really blows. did you have it jetted right? those sleds should be reliable but ya things do happen. good to see the snowies have snow.
 

·
Registered
Joined
·
963 Posts
^^ yeah if you didn't re-jet it and clutch it for that alttitude then that would make sense.
 

·
Registered
Joined
·
80 Posts
I have climbed that hill in the bottom picture many times and the middle pict is the top of the hill. Thats a good hill. Its one of the best ones in the snowies. Looks like the snow was pretty good. Sorry to hear about your sled.
 

·
Registered
Joined
·
2,477 Posts
hey check this link out. maybe its related to your sled.

http://www.snowest.com/fusetalk/messageview.cfm?catid=8&threadid=290771&enterthread=y
 

·
Registered
Joined
·
321 Posts
Discussion Starter #6
the sled was jetted and clutched correctly.The sled ran flawless for a couple of days then started acting up.the tach quit working also so i think its elec.I lost spark to the plugs.thanks WY_rider for the article.
 

·
Registered
Joined
·
131 Posts
hey wy rider, i could of told you that the snowies had snow, so just get your a$$ down here, and prox do you live anywhere close or did you take a trip here...cause if your taking a trip, your must live on the edge..to drive all the way over here this early in the season..but im glad to see you had a good time...
 

·
Registered
Joined
·
321 Posts
Discussion Starter #8
Just got a call from my dearler about what went wrong on the sled.they say i had a bad connection down by the stator/recoil area.the the wires that come out of the stator melted together and shorted together.so next week it will be up and runnin for the Jan.trip back to the snowies.[:D]
 

·
Registered
Joined
·
1,416 Posts
that sucks but look like the conditions were nice
 
1 - 10 of 10 Posts
Top