Snowmobile Fanatics banner

1 - 5 of 5 Posts

·
Registered
Joined
·
193 Posts
Discussion Starter #1
92 Indy 500 EFI. The ignition switch went bad on it so I replaced it. They sent me a two position switch (the original was three) and even in the off position and the key out the green light on the dash (RDY) stays lit.

Only way to turn it off was unhook the battery.

Went to the shop and got a three position switch that they looked up as being the correct switch for the machine but same deal. Even in the off position with key out the light stays on. The third position runs the EFI fine which is good but the off position is apparently still hot. Third position primes the sled with battery power with the EFI.

Any ideas on how to fix this other than the battery disconnect switch I have purchased to install as a work around?
 

·
Registered
Joined
·
193 Posts
Discussion Starter #3
Good question... I will check that out when I get home...
 

·
Registered
Joined
·
5,400 Posts
[galleryattach=5068]

Sounds like that light got connected up wrong. See how the lighting system is not connected to the battery at all. You need to trace the wires and find out where it connected to the potential from the battery.
 

·
Registered
Joined
·
193 Posts
Discussion Starter #5
The only thing that wouldn't make sense is how it worked with the switch that it came with? It all worked fine until the switch went bad... all of a sudden I just couldn't turn the key... it is only since the two new switches that the problem came up... but I will try tracing wires when I get a chance...
 
1 - 5 of 5 Posts
Top