Snowmobile Fanatics banner
1 - 11 of 11 Posts

·
Registered
Joined
·
632 Posts
common problem on the polaris, but i know it can be done. Not much help, i know.
 

·
Registered
Joined
·
918 Posts
There supposed to mount on the left side of the block. Mine are powermadd mounts but they are basically the same thing. I have it arced under the bar and it works fine. It did take awhile got me to figure out how to do it to as the directions kinda took my lever out of commision(sp). Ill attach a pic below

Personal protective equipment Vehicle Snow Motorcycle accessories Helmet



*EDIT* also it may sound dumb but make sure to put the mount under the handwarmer wires. I went through 2 sets before i really figures out what was wrong.
 

·
Registered
Joined
·
873 Posts
Dekk70 said:
There supposed to mount on the left side of the block. Mine are powermadd mounts but they are basically the same thing. I have it arced under the bar and it works fine. It did take awhile got me to figure out how to do it to as the directions kinda took my lever out of commision(sp). Ill attach a pic below

Personal protective equipment Vehicle Snow Motorcycle accessories Helmet



*EDIT* also it may sound dumb but make sure to put the mount under the handwarmer wires. I went through 2 sets before i really figures out what was wrong.
I didn't realize it was supposed to go under the handle, good idea [thumb] I always put mine over it. Makes sense both ways. Trial and error

Chad
 

·
Registered
Joined
·
918 Posts
polarisIQmn said:
Dekk70 said:
There supposed to mount on the left side of the block. Mine are powermadd mounts but they are basically the same thing. I have it arced under the bar and it works fine. It did take awhile got me to figure out how to do it to as the directions kinda took my lever out of commision(sp). Ill attach a pic below

Personal protective equipment Vehicle Snow Motorcycle accessories Helmet



*EDIT* also it may sound dumb but make sure to put the mount under the handwarmer wires. I went through 2 sets before i really figures out what was wrong.
I didn't realize it was supposed to go under the handle, good idea [thumb] I always put mine over it. Makes sense both ways. Trial and error

Chad
Yep this way the park lock still works [thumb]
 

Attachments

1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top