Snowmobile Fanatics banner

1 - 6 of 6 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter · #1 ·
Hey guys, I just got my sled back from the shop. I had the Hauck hushers installed on my 03 Mountain Viper. Three separate pipes exit the tub but don't have a ring to plug the hole. I hope this makes sense . . . Most pipes come together with some kind of bracket to, not only hold the three pipes, but plug that darn hole up. So basically, I am trying to figure out a way to plug it. The dealer threw a ton of heat tape and told me how the Haucks need to come with this bracket but don't. Ok, I'm done babbling . . .[:D]
 

·
Registered
Joined
·
5,686 Posts
Here is the info for Hauck. Contact them to see what they suggest you do.


Hauck Power Sports, Inc.

2072 19th St/West Ave

Rice Lake, WI 54868

(715) 234-6195

Fax (715) 234-5485

Tech (M-F 1-5) (715) 234-5647

Email: [email protected]
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #3 ·
Thanks ACE!
 

·
Registered
Joined
·
528 Posts
A sheet metal shop should be able to cut a piece of aluminum for you to block the hole in your belly pan.

http://www.hauckpowersportsinc.com/Page%204.htm

With the extra power those pipes are making I'd suggest replacing your front PTO motor mount with the 3-bolt SRX mount and adding a torque arm. There have been problems with the motor mount bolts shearing off.
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #6 ·
Thanks for the info Canuck. I did put a torque arm on and had read about the motor mount shearing in other Vipers. I'll check into it. These pipes are coily SOBs! ALl over the damn place. . . I can't wait to rip with em. Pretty quiet compared to my buddy's Benders too.
 
1 - 6 of 6 Posts
Top