Snowmobile Fanatics banner
1 - 20 of 25 Posts

·
Registered
Joined
·
481 Posts
Discussion Starter · #1 ·
I have a 1978 Arctic Cat Jag 2000 with a 550 cc Spirit engine in it. I had it out the other day preping it for this winter and I noticed that the one head was leaking and causing it to run rough. I got a wrench and tightened down the nuts a little (which were only about finger tight.)

I was curious if anyone knows the proper torque that the nuts on the head are supposed to be set at. The sled is in excellent condition and ran great last year.

Thank you,
Max Trax
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #3 ·
I tightened them snug but did not want to pull the studs out of the block. I was able to get ahold of a repair shop and they said that heads typically are tightened to 22-29ft/lbs.

When I tightened them that did not seem like as much as I would have thought, but I figure they know better than me. I didn't know if someone had an old service manual they could check or not.

Thanks
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #5 ·
It is neither liquid or fan cooled. The one that I have is free air cooled. I made sure they were all loosened then retightened all of them down to 25ft/lbs. (I figured that would be good enough for now as we got enough snow to cover the grass and I couldn't wait!)
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #6 ·
My owners manual also says that it should have an air filter type device on the carbuerator (silencer). Is this an important as mine does not have one?

Also, what speeds should I be able to expect out of my sled? (It doesn't have a speedo but I will be able to check by gps.)

Thanks
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #10 ·
Any info on the silencer. My owners manual says "The purpose of the silencer is to quiet teh intake of fresh air into the carburetor and to catch fuel that is "spit back" out of the carb. If the silencer is removed and the engine is run, poor performance will result."

I thought it had good performance but it is my first sled, could addding one improve my performance?
 

·
Registered
Joined
·
2,487 Posts
Also has similar properties to the pipe. It uses the reflected pulse of that air moving through it to help push more of the air/fuel mix into the engine.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #13 ·
Thank you. I called a local salvage yard and he said he will probably be getting one in soon, so I will probably get one.

I was out riding the other night 20* Farenheit. I rode around for about 5min before I noticed a funny noise (not a good one) comming from my engine compartment. I imediately shut it off and opened the hood to find my exhaust pipes/muffler glowing. I figured the sound was the engine backfiring so I rode back and parked her.

I checked the plugs today and they indicated the proper heat range.
I also reset the carb to my original manual's specifications.
I rode again today and it began to do the same thing.
The mixed gas is the stuff from last March, so I pumped it out and put in fresh.

Could that have been the problem?
How do I check the timing?
Is the engine crank case supposed to have gas oil mix going in/out of it? (I don't think it does)
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #14 ·
I really wish I knew if the timing was right or not. Does anyone have a picture or description of how to check the timing? I know it needs to be 18*BTDC but that is it.
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #15 ·
Earlier this year I had to fix the choke inside the carb because it was stuck due to being stored for 17 years.

Is there anything that could have changed to make it backfire? I would like to get this fixed before we get into winter bigtime.

Thanks
Andrew
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #17 ·
I did adjust the timing so it would fire earlier... That was the problem. I really want to check the timing and make sure it is correct but do not know how.

Is there a timing light for these or just time it by ear?
Thanks much,
Andrew
 

·
Registered
Joined
·
481 Posts
Discussion Starter · #19 ·
It was, until I adjusted the timing sooner. It isn't backfiring now but I don't want to screw up my engine with the wrong timing.

I am pretty sure it is close but still don't want to take a chance because the sled is incredible condition.
Thanks
Andrew
 
1 - 20 of 25 Posts
Top