Snowmobile Fanatics banner

1 - 9 of 9 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
My Exciter after starting cold seems to run good but, after 10 minutes it bogs down and progressively gets to the point where it will not even move under it's own power. It will continue to idle but, won't even rev up beyond 5000 Rpms with the track lifted. This engine has a fresh top to bottom rebuild with seals, gaskets, pistons and rings. The stator coils and ignition coils check within specs. before and after it bogs. There is still 130 Lbs. of compression in both cylinders after it bogs down. The carbs are clean with all new gas lines and filter. If you let it cool down it will run for another 10 minutes. Any ideas..... ? (CDI ?) Thanks Chuck
 

·
Registered
Joined
·
108 Posts
What color are the plugs when it does this? Usually if its lean putting on the choke will help. However, you say its okay cold. Cold engines can handle more fuel than hot ones. Are your choke pistons seated fully? Enough play in cables? When you did your rebuild did you leave it stock? If you modded anything you may have to re-jet. Next time it does it quickly pull a plug & see if its rich or lean
 

·
Registered
Joined
·
149 Posts
Discussion Starter #4
Thanks for the replys. I have the choke adjusters backed off the whole way to make sure they are seating (I pull it from a warm garage). The plugs appear wet when pulled and how can I read them since, I only start to get it to operating temp. when it bogs ? Setting it to half choke doesn't help. I have bled the cooling system and it is circulating since the exchangers get warm ?
 

·
Registered
Joined
·
474 Posts
I'm having the same problem right now with an 89 phazer, but I don't think fuel is the issue. You said you have checked the Ignition coils, i haven't checked mine yet. But I think it could also be the CDI on mine. Could be the same for yours? Mine would run for about 20 mins until it would start to die and end up in the same state as yours not being able to move. After it cools for 30 mins, it will run again also. But now I cannot seam to get the problem to come back after it did it for a solid week. 2 different motors though, so you could have a fuel problem. I don't think it has anything to do with the choke, and if you used the same jets in the carb after rebuild, and didn't do any adjustments, your carbs should be fine I figure.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #6
SRXSRULE It sounds like you could have a bad connection, bare wire rubbing, loose or dirty ground in order for the problem to disappear ?
 

·
Registered
Joined
·
102 Posts
Vmax it sounds like you are running rich for sure. Just to clarify, you say you backed the chokes off? Do you mean you screwed the adjuster out? If so thats backwards... you want to loosen the jambnut and screw the adjuster in/clockwise to seat the plungers. Pull them off and check them for corosion, they might be sticking open in which case adjusting them isn't helping. Assuming your jetting is correct, it could be a improperly adjusted or sticking float, worn float plunger, worn needle or seat. Is there a puddle of gas in the carbs when the machine is off? Hold the throttle wide open and pull the engine over a few times with the kill off and see if gas continually flows through the neeedle jet... if so check the floats. I'm not sure how to test the needles and seats for wear other than visual inspection... I think it takes a pressure test... check floats and other stuff first.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #8
It Runs.... ! ! ! Thanks for all the help ! I bought it with a bad crank so, I never ran it until after the rebuild. Altough, I cleaned the carbs the floats were set at not quite 17mm's and the specs are 17.1 to 19.1mm so, I set them at a strong 18mm and no more bog ! I do have the air screws out 1/2 turn futher than the spec's. call for so, do I need to drop the pilot jets a size down ? Thanks Again everyone !
_________________
Less is more.....
 

·
Registered
Joined
·
349 Posts
get new plugs that burn hotter
 
1 - 9 of 9 Posts
Top