Snowmobile Fanatics banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
[red]I just bought my first snowmobile, a 1980 Yamaha Enticer 340. When it idles it sort of putses around like its missing. What might the problem be? New spark plugs maybe? Also on the left hand side there is a switch that says high on top and low on bottom, what is this switch for? thanks [/red]
 

·
Registered
Joined
·
1,527 Posts
I would say its flooded and the high and low thing, that is probably for dims(low)
and brights(high) switch.
 

·
Registered
Joined
·
2,124 Posts
pull the carbs and clean them sounds like a half plugged pilot jet.could also be a fouled plug pull plugs see if ones wet . the switch could be for hot grips you could trace the wire see where it goes.
 

·
Registered
Joined
·
55 Posts
I agree, the switch is most likely for hand warmers. Many of those sleds didn't come with hand warmers from factory. If someone added them, the switch could be anywhere.
 

·
Registered
Joined
·
329 Posts
I had a 79 enticer that would eat up 10 sets of plugs a year, Why I have no idea, My shop guy set me up with a set of NGK BR8EV spark plugs and I have never fould a plug since. I am still looking for a stator plate and coil set up if any one has it.
 

·
Registered
Joined
·
1,969 Posts
clean the carburetor and put new plugs in it. the switch is probably a handwarmer switch like mentioned about. i had a 1981 excell 3 340 when i was a kid which is a very similar sled. i think the hi/low beam switch for the light was a push button that clicked in and out to switch the beams. it's probably a dirty carb issue. also check to see if you have good spark.
 
1 - 7 of 7 Posts
Top