Snowmobile Fanatics banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Out for a ride yesterday on my 95 Indy Trail, and the right track suspension spring broke. I replaced both today and now it seems locked or frozen. With both me and my wife sitting on it the sled doesnt drop at all. I also noticed that all 3 straps are dont seem tight (they are bowed) anyone have any thoughts what may be wrong or have any experience with this xc100 suspension.
Thanks
 

·
Registered
Joined
·
227 Posts
When you had the suspension out and the pressure of the springs released, did the suspension knuckle over the wrong way? Where the back shock mounts on the bottom of the suspension there is a pivot point if it gets to the point where it pivots upwards (I think up) it will not allow for travel. It will wedge itself. You might have to release the spring pressure and get a pry bar and roll it back over.
Just a thought!
 

·
Registered
Joined
·
8,108 Posts
nice name!

I would agree with the previous post. It isn't very often a suspension freezes up. Usually if they do, it's from a broken shock too..., or other majorly broken parts.

-Dean
 

·
Registered
Joined
·
2,573 Posts
Are they the right springs? If you jump on it does it move?? or is it totally frozen? My thoughts...totally froze...check something else. Will move...check to make sure you didn't get stiffer springs.
 

·
Registered
Joined
·
2,307 Posts
Sounds to me like something wasn't put back in exactly the way its suppose to go. I'd have to go with j-2-800's idea on this one. Check where the shocks conect to the shafts, to be sure they will allow for proper movement.
 
1 - 5 of 5 Posts
Top