Snowmobile Fanatics banner

1 - 20 of 21 Posts

·
Registered
Joined
·
364 Posts
Discussion Starter #1
polished the clutches today and cleaned up the bay. what ya think ?
[attachment=52253]
[attachment=52257]
[attachment=52256]
[attachment=52255]
 

Attachments

·
Registered
Joined
·
1,527 Posts
Well, its shiny and looks good! Just need to get a motor in that thing.
 

·
Registered
Joined
·
2,916 Posts
I hope you didnt polish the sheeves!!!


otherwise, looks good!
 

·
Registered
Joined
·
364 Posts
Discussion Starter #6
no i did not polish the sheeves but i did scoch brite them
 

·
Registered
Joined
·
901 Posts
looks really good. but its missing something... lol dang motors eh.
 

·
Registered
Joined
·
3,449 Posts
^^^^^^^^^^^^^^^^^^^^^
more along the lines of not having a motor....

Hey 91530ext when are you going to get the new powerplant for that thing?
 

·
Registered
Joined
·
348 Posts
I would be installing acouple flinstone pedals in that thing by now lol J/K bro hope ya gitter dun soon.
 

·
Registered
Joined
·
1,350 Posts
Well they always say...

If it don't go,
Chrome it!!!!

Looks good man!!

DW
 

·
Registered
Joined
·
1,165 Posts
thats some great shining
 

·
Registered
Joined
·
364 Posts
Discussion Starter #15
well i was told today that the new power plant will be done this week. we should have it in by this weekend if everything goes rite.
 

·
Registered
Joined
·
364 Posts
Discussion Starter #16
Originally posted by STEVE650
[br]How much time to clean the clutches??? They look so nice!
it did not take long at all i ues this stuff caled lizard spit along
with a buffing wheel you can see it here www.lizardspit.com and this stuff works better and faster www.heavymetalpolish.com
 

·
Registered
Joined
·
1,230 Posts
Originally posted by STEVE650
[br]I was thinking I'm the only member here with the sled not ready to go[:D]
definatly not the only member with there sled not ready to go. mine will be ready to go christmas break
 

·
Registered
Joined
·
1,095 Posts
Originally posted by mcc-bri
[br]
Originally posted by STEVE650
[br]I was thinking I'm the only member here with the sled not ready to go[:D]
definatly not the only member with there sled not ready to go. mine will be ready to go christmas break
I'm part of the not ready club[V] hopefully this weekend we can get it run'n[:D]
 

·
Registered
Joined
·
1,696 Posts
dont worry no snow anyways lol am i one of the few people that knows that his motor had blown and needs to be fixed?
 

·
Registered
Joined
·
364 Posts
Discussion Starter #20
well i should have the motor in and running by the weekend
if all goes well and no problems getting it in. so far i have $4900 into it and one vary understanding wife thank god.
 
1 - 20 of 21 Posts
Top