Snowmobile Fanatics banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,102 Posts
Discussion Starter · #1 ·
so im workin on this indy 500 and its starting to frustrate me. its got a 500 l/c engine i rebuilt like 2 years ago and its got good compression. it runs great but then it will just bog out to a stop when its at idle. its idleing at 2000 rpm. i sprayed carb cleaner at the crank seal and it was didnt rev up rhe carbs are clean. would a fuel pump just die out cuz thats what it sounds like is going on?
 

·
Registered
Joined
·
3,418 Posts
My guess:
Check your pilot jets. This controls idle to mid range. theres 8 tiny holes and one right down the middle of the jet.
 

·
Registered
Joined
·
1,102 Posts
Discussion Starter · #3 ·
they are clean. same with mains

and floats dont have holes on them either

its wierd cuz my buddy has the same exact sled with the same problem. too.
 

·
Registered
Joined
·
175 Posts
Something electrical maybe?
 

·
Registered
Joined
·
1,102 Posts
Discussion Starter · #5 ·
thats what i thought too but i put a spark tester on it until it dies and it has spark the whole time. im gonna go see how mucha new pump or a rebuild kit is.
 

·
Registered
Joined
·
1,479 Posts
polarisripper28 said:
thats what i thought too but i put a spark tester on it until it dies and it has spark the whole time. im gonna go see how mucha new pump or a rebuild kit is.
a new kit is no more then 10 bucks
 

·
Registered
Joined
·
1,102 Posts
Discussion Starter · #7 ·
ya i got the kit. i dont think its the problem though. i got it goin again and then pull off the fuel line and it was pumpin great. its deffinetly a fuel problem. im gonna clean the carbs one last time. i wish i had the oney for a paint can of that parts soaker. we had it at work and it was awsome.
 

·
Registered
Joined
·
1,102 Posts
Discussion Starter · #8 ·
well i got it running great the air mixture skrews were way out. which is wierd cuz when i cleaned the carbs the first time i turned them to 1.25 out and then it ran great for like 25-30 min. go to put it on my trailer(2 place open by myself=pain in ass) and it dies. so disapointing.
 

·
Registered
Joined
·
1,102 Posts
Discussion Starter · #9 ·
so i still cant get it goin. i found a whole bunch of problems but none of them are the real problem. i found out that the jet sizes were not even close and non of the jets matched each carb. what else would cause it to die out after it sits for a second at idle. sometimes its only a second and sometimes its longer. any help would be awsome. snow is on its way
 

·
Registered
Joined
·
175 Posts
Have you checked the fuel pickup line inside the fuel tank?
 

·
Registered
Joined
·
1,102 Posts
Discussion Starter · #12 ·
well it blew up. got it running good. went to ride it around the yard and started to knock turned it off and turned it over by hand and then it got stuck. looked in the carb boot and the skkirt shatterd.
 

·
Registered
Joined
·
45 Posts
my gawd that sucks man... i have the same exact problem with my indy dude i cant fckn figure it out for the life of me but my carb is wrecked but still i dont think its that either i think its something to do with like yours did... it will like only idle and then sometimes it runs good and when u get it up to driving speed and putt around and then punch it it bogs all the way and sometimes comes to a stop
 

·
Registered
Joined
·
1,102 Posts
Discussion Starter · #14 ·
ok well i think i figured out the problem right before it blew. the idle was turned too low. i turned it up and it was at high idle for a second then went down to a normal idle. kinda like my ultra, it will idle high then go down to a normal idle. i just wasnt allowing it to go down. so instead of idleing it would just die. not sure if that was really the problem, but that was the last thing i tried and it seamed to work.
 
1 - 14 of 14 Posts
Top