Snowmobile Fanatics banner
1 - 11 of 11 Posts

· Registered
Joined
·
2,738 Posts
The problematic 550's were in the edge chassis due to poor cooling from the small amount of surface area on the vents in the edge hood. They were good in the Gen II chassis in 1999-2000, and I believe the IQ chassis are better as well.

However for edge 550's, if they were ridden balls to the wall hard, they were fine because more air was flowing under the hood due to higher speeds. When cruised at legal trail speeds and less for long periods of time, that's when they had the problems. We had a 2001 Supersport for a few seasons and never had any problems because my brother and I beat the p*ss out of it.
 

· Registered
Joined
·
2,738 Posts
rich1374670x said:
How does one fix. A friend of mine has a 340 indy classic that does the does the same.
does the same what? it repeatedly burns holes in the pistons? you can't just replace the piston/cylinder and ride again, you have to fix what cause the piston failure in the first place otherwise it will happen again.
 

· Registered
Joined
·
828 Posts
I dont think the statement is accurate - just because it ran hot, doesnt make sense it would put a hole in the piston. If it gets hot and doesnt get cooled, then it should seized up. As for a burning a hole in a piston, it means it ran lean or bad crankseals or bad CDI. I may be wrong but thats what it sounds to me. ANYONE? WL
 

· Registered
Joined
·
37 Posts
my wife burned down her 08 550lx last year. was still under warranty. buddy did the same to the same sled last year. we had 10 difference on the clocks. the dealer fix them and added a oil recircluation system. polaris said air bubbles form in the oil lines. We put on 1100 miles this season and no problems buddy of mine put on 1300 and nothing so i guess that might be the fix.
 

· Registered
Joined
·
713 Posts
they seemed to have oil pump problems. that's why i mix the 05 touring's gas. haven't had a burn down yet.. had it for three years now and have about 5k miles so far and still running.
 

· Registered
Joined
·
72 Posts
Maybe someone can help me out?
I bought a 01 supersport from another member on here(really good guy by the way), anyhow theses a hole in one piston, Im kindof running out of time to have it inspected for the RIV.

Original plan was to put a 440 fan out of a 97 sport that Ive had sitting in the garage for years. With the motors side by side, the 440 has an oiler fitting on the bottom end to the clutch side of the oil pump,and a different wiring harness. So I was thinking find a XCF or PRO-X fan wiring harness,re jet, re clutch, and regear.

OR

freshen the top end on the 550, put it back in and go for my inspection. then clutch,jet,gear,new track,etc.

Either way ill be clutching,jetting,doing the gears and adding a 144 track.
The spare 440 I have is rebuilt everything bottom to top and has the steel update oil gear drive.

Sorry, this is my first sled thats in the 2000s hahaha
 

· Registered
Joined
·
3,214 Posts
I'm sorry officer, I'm speeding because I don't want my sled engine to burn down.....I will have to try that one
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top