Snowmobile Fanatics banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,624 Posts
Discussion Starter · #1 ·
I have a 93 xlt. When I take off the radiator cap on the engine i can see the head bolts, so i add some and go and ride. when i am done i can see that some antifreeze came out the overflow cap. I wait till the next day and check in the engine again and it is low. Is this normal? or am I losing coolant? If so what is wrong.
 

·
Registered
Joined
·
1,624 Posts
Discussion Starter · #3 ·
ok. anything else I should do? Is this normal?
 

·
Registered
Joined
·
125 Posts
No that is not mormal. Check all hoses and clamps and cap. I had a 93 XLT that the little plasic hose that hooks to the water pump and runs over the recoil had a small crack by the clamp.
 

·
Registered
Joined
·
1,624 Posts
Discussion Starter · #5 ·
ok I will check that. I dont see any green puddles anywhere so i dont think it happens when it sits.
 

·
Registered
Joined
·
45 Posts
ya anwser that question above if everything looks good it cud be going out the exhaust in which would be the head gasket... also turn it over or find a way to check the heat exchangers have the machine up to temp and see if it is pissing out because u say you dont see antifreeze but the snow could wash it in and u may not see so clean the exchangers and check good luck
 

·
Registered
Joined
·
2,922 Posts
I had that problem earlier this year. Bad coolant cap was the problem.
 

·
Registered
Joined
·
3,888 Posts
I would say the cap is probably the most common problem if you don't notice any leaks, however, sometimes when the head gasket starts to go out it will it allow air to leak by during the compression stroke but doesn't let coolant leak into the cylinder.

The only way I know to verify that, is to remove the radiator cap and turn the engine over. Coolant will shoot out if it's bad. I've had this happen on a car and a dirt bike, both of them kept dumping coolant out the overflow.
 

·
Registered
Joined
·
2,382 Posts
Also check the worm gear, I had a seal on it that went bad thus loosing coolant.
 

·
Registered
Joined
·
1,624 Posts
Discussion Starter · #11 ·
So i ruled out the head gasket. Getting a new cap in a half hour. will let you know what happens. If it still does it I have a leak somewhere that isnt obvious.
 

·
Registered
Joined
·
1,624 Posts
Discussion Starter · #12 ·
Well that didnt do it. So I guess I have to start looking for a leak.
 
1 - 12 of 12 Posts
Top