Snowmobile Fanatics banner
1 - 10 of 10 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
I have a 1990 yamaha exciter 570 was ridingf the other night and it just up a died. checked comperssion and have 120 in on side and 30 in the other does it sound like a piston or a seal problem?

Thanks for and help
 

·
Registered
Joined
·
252 Posts
Pull the head and take a look going have to rebuild anyways.
 

·
Registered
Joined
·
685 Posts
I agree as well....30psi is dead. Tear into the motor and you will soon find out, its not always easy to tell what happened on a particular cylinder without seeing it.

Bottom line unfortunately, your going to have to rebuild.


Keep us posted.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
I am going to pull the head today and see. the other question I have is that the sled seemed to bog when I took off like it was flooded and then seemed to clear up but only went about another 1/4 mile and quit. then when we brought it home went to the garage after letting it sit for a while the floor was covered with gas but the gas was leaking out of the carb on the other side could a carb prroblem have burt/ blown the piston[?]

Thanks for the replys

Fred
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
Yea it was burnt I and guessing due to lack of fuel but the bad thing is the clip holding the piston to the wrist pin came out and scored the jug ...Garbage now.

But the good thing is I found a used jug and in talking to the guy he had a new piston kit for it and the best part only $30.00 for both talk about falling and smelling like a dozen roses

I think the problem is the carbs going to clean the tomorrow and get a top end gasket kit

As for the Shotgun I only shoot things that are living and right now its dead so why waist the shell


will keep you posted

fred
 
1 - 10 of 10 Posts
Top