Snowmobile Fanatics banner

1 - 3 of 3 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter #1
Hi, i have a '89 Formula MX 462 LC and i just wanted to know if anybody else has had one. I would like to know what the approx. top speed is, and any 0-60'skm/h, 0-100km/h, etc...

Does any body know of any repeated problems with this sled?? P.S. Does anybody have a wiring diagram for the handwarmers? I cant get mine too work. Also, i have a CD box that was put on and i dont see a place to mount it onto, if anybody knows were tell me. One last thing, my pullstarter keeps slipping and every like 4 pulls it catches and actually pulls the motor over, it rewinds fine and everything, but it slips. I've tried various things but dont know what is wrong. Any ideas??


Ok, ur help is greatly appreciated..

Neil

Ski-Doo- Better than Polaris and faster than Arctic-Cat
 

·
Registered
Joined
·
9,619 Posts
for the handwarmers, i would just start checkin wires leading to them, get a 12 volt tester (correct me if this dont work) and see if everything has power that is supposed to, check for loose grounds too.

taking apart the recoil and seeing what is broken in there is probably the thing to do for the rope slipping and not catching. wanna get the fixed b4 witner cuz it might be a big PITA to get it started if it only turns the motor over ever 5 tries...lol

PS:ur signature is kind of brand bashing, i have no authority over it, but i would change it somewhat......IMO


When's Winter Coming Back?​
 

·
Registered
Joined
·
36 Posts
lol i love your signature, but it's funny i've never had ANY problems with my POLARIS



/snofan/../images/users/95INDYSPORT-NY/top2.gif

POLARIS--THE ONLY WAY OUT

The Snowbelt starts in Camden!

T.C. Riders' scenic and superbly groomed trails are your

GATEWAY to the TUG HILL! www.tcriders.com
 
1 - 3 of 3 Posts
Top