Snowmobile Fanatics banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,898 Posts
Discussion Starter #1
well heres the scoop ive been working on a kids phazer 2 i cleand the airbox, carbs checked the rings they could be replaced but he doesnt have the money now. it still has prolly 115 in each cylinder so its fine but it wont idle unless the choke is on its running with out the choke on witch is the first in a long time. thats from the carbs being cleaned. but i was wondering what could be casuing this. it is still fairly warm out when we were starting it. i thought maybe bad spark so either coils or coil pack (cdi). any thoughts.
 

·
Registered
Joined
·
26 Posts
crank seals?
 

·
Registered
Joined
·
474 Posts
I've had to replace a few secondary coils before, but usually because they just won't spark at all and they drop a cylinder. How many miles on the sled?
 

·
Registered
Joined
·
366 Posts
I assume you have adjusted the low speed jet screws on top of the carbs? They usually have to be set somewhat rich at idle to prevent a bog on takeoff. Make sure every jet in the carbs is clean. Run a corresponding sized piece of wire back and forth (if you don't have number drills) through all the jets. There is a small pilot jet in the roof of the float chamber and there is a tiny jet (not removable, just a hole) at the bottom of the mouth of the carb that could cause the problem you describe.
 

·
Registered
Joined
·
1,898 Posts
Discussion Starter #5
cleaned the jets right up, i thought crank seals at first, the carbs are all set up right, but il check low speed jet screws once more. i was told from a guy that used to run phazers alot that its a coil so im really thinking thats what it is but seems more like its losing gas.
 

·
Registered
Joined
·
26 Posts
gotta be fuel, why would choking it cause it too run better? if it wasnt running lean?
 

·
Registered
Joined
·
1,898 Posts
Discussion Starter #7
ya i no, it seems like the throttle completely shuts wehen you let off. so we just tried turning up the throttle, it ran a little better but still didnt want to idle. so any more ideas or should we rip back into the carbs. i only cleaned one of them and had to leave for co-op so im assuming the other got done right to. but i geuss il have to check today.
 

·
Registered
Joined
·
54 Posts
sounds like the pilot jet is clogged or the passage from the pilot jet and the fuel screw. take all the jets out and soak them in OMC engian tunner, found at a marine dealer then spray out jets with carb clean.. set fuel screw at 1 1/2 turns out from seated it should run it there are no air leaks
 

·
Registered
Joined
·
1,898 Posts
Discussion Starter #9
ok thanks its at the school so monday i will do that.
 

·
Registered
Joined
·
1,898 Posts
Discussion Starter #10
well i got ir running again cleaned pilot jets and someone turned the idle screw all the way in[:(!], that would do it i checked it over and it was fine before the carb cleaning but i geuss thats why you cant leave things at school these days. i was pretty excited about how good it runs now. and ive got another phazer 2 to be working on. it has 35,000 original kilometers!!!
 

·
Registered
Joined
·
26 Posts
35 000? im glad too hear these things will last that long, i just dumped $1300 into the one i bought last yr.Too da mn cold too ride it though, i wish i knew a good yamaha guy too help me jet it right, I just put a bender racing motor in it and seems too be pinging so im a bit worried!!! I`m scared too run it too long the way it is, but i must say the old girl is fast as hell!!
 

·
Registered
Joined
·
1,898 Posts
Discussion Starter #12
ya the one with 35,000 runs good but if its warm itl knock like all hell. the first time i drove it, it scared the crap out of me i was expecting it to blow.
 

·
Registered
Joined
·
366 Posts
Originally posted by Sledneck_dsmer
[br]well i got ir running again cleaned pilot jets and someone turned the idle screw all the way in[:(!], that would do it i checked it over and it was fine before the carb cleaning but i geuss thats why you cant leave things at school these days. i was pretty excited about how good it runs now. and ive got another phazer 2 to be working on. it has 35,000 original kilometers!!!
Could you post a picture of the odometer Sledneck? It's not that I do not believe you, I would just like to have a picture of it. And what year is it?
Thanks, PZ1
 
1 - 13 of 13 Posts
Top