Snowmobile Fanatics banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I am having a strange problem with a 91 phazer. When idling only one cylinder gets fuel until I give it a shot of choke. It runs fine at higher RPM but as soon as I slow down one cylinder cuts out again and you almost go over the windsheild. I have put a different set of carbs on and a different coil but it is still doing it. Am I missing something simple here?
 

·
Registered
Joined
·
55 Posts
maybe you have a restriction in your fuel pumps outlet to that particulaur carb. collapsed fuel line that only feeds fuel under high RPM and when the engine is at lower RPM whech doesn't create as much vacuum to the fuel pump to push the fuel through the line. Or maybe time for an Arctic Cat!! [:D]
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
The trouble followed the engine when I swapped it out so it is using different fuel lines. I am starting to think I may have a bad crank seal. I'm not quite desprerate enough to drive a cat.
 

·
Registered
Joined
·
48 Posts
i agree on the cat thing i dont think it would be a crank seal cause at higher rpm you said it kicks in if the seal was bad at higher rpm it should get worse because you are sucking more air in if you are getting spark on both plugs i would start with carbs and gas delivery to the carbs also check fuel filter
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
It's as good a place as any to start. I'll take a look again.
Thanks for all your help
 

·
Registered
Joined
·
539 Posts
sounds to me like you have a plugged pilot jet in the carb.
time for a carb cleaning.
 
1 - 6 of 6 Posts
Top