Snowmobile Fanatics banner
1 - 13 of 13 Posts

·
Registered
Joined
·
2,477 Posts
looks like she got hot.

lack of lube Im guessing.
 

·
Registered
Joined
·
5,400 Posts
Originally posted by WY_rider
[br]looks like she got hot.

lack of lube Im guessing.
I agree.
 

·
Registered
Joined
·
247 Posts
there's a golf cart place in tea, SD, and i saw a piston there that looks like a caveman carved it using a mammoth tusk or something. i know, pretty random, but it was absolutely crazy.
 

·
Registered
Joined
·
764 Posts
[attachment=57431]
thats probably my favorite piston blow, we're thinking bad gas, but not sure, any ideas?, it was a 580 zr , gone now, but just wondering what everyone thinks might of caused it
 

Attachments

·
Registered
Joined
·
394 Posts
OH MY GOD !!!!
This is exactly the same look as my neibors pistons !!!!
We just spent all weekend putting new piston and rings in his 89 mach 1.What could this be you say???? The sled motor had a clog jet and leaned out and also his main jets were off (to small).I'll tell you what though that freakin sled ripped till it blew up!
also after closer inspection,one of his gaskets were bad and sucked to much air and also leaned it out.All the things together spells disaster very quick.The olny good thing that came out of this whole thing was that he scored a pair of piston and rings off ebay from a used parts place out west somewhere.well after the hone job and the new install the old ski doo is rippin again.sorry to here the terrible news.I hope you get the sled up and going soon because the snow is coming more and more lately.take care I hope I helped.
sparkyd31
 

·
Registered
Joined
·
6,424 Posts
Not enough oil, and not cooled right ( water pump ). Same thing happened to my inviter. Won't be happening again. I think I still have a couple burnt pistons in one of my drawers.. I'll see if I can get some pics.
 

·
Registered
Joined
·
1,165 Posts
that sucks
 

·
Registered
Joined
·
2,019 Posts
Some of those pics make me cringe [V] [Wow]
 
1 - 13 of 13 Posts
Top