Snowmobile Fanatics banner

1 - 9 of 9 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
I just bought a 92 mach 1, works great when it'll run. I put new plugs in it and it ran great for a couple hours. It fouled the plugs, i put new plugs in it and it runs great again. I'm stuck between wether it's the jetting or the oil injection setting. If anyone has had any of these problems it be great to get some ideas before i tear it appart.
Marty
 

·
Registered
Joined
·
49 Posts
my exciter did the same thing but only on one cylinder, the problem that i found was that the cylinder that was fouling out after awhile had its choke cable higher than the other so it was getting more gas. I would check your choke operation just to make sure
 

·
Registered
Joined
·
366 Posts
my 95 Xlt was fouling plugs like crazy. I used to use 3 to 4 plugs a ride. I changed the needles and seats and haven't changed one since. Plus it really woke it up. runs alot better on the bottom end.

Rich
 

·
Registered
Joined
·
2 Posts
does any body know the proper way to check needle valves. i have a problem with the crank filling up with gas, valve is clean and not sticking.
 

·
Registered
Joined
·
49 Posts
I was blowing plugs on my 02' renegade last season on mag side. It was as simple as a slack muffler manifold. Check your manifolds & head bolts. simple stuff like that causes loss of back pressure and blows plugs
 

·
Registered
Joined
·
22 Posts
Discussion Starter #6
i'm going to tear this thing down tommorow and figure out the problem, does anyone have the hetting specs for this, and does anyone know what the setting for the oil should be?
thanks
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
what i meant was jetting specs. I think the jets that are in it are too big. it's a 92 mach 1 617cc
 

·
Registered
Joined
·
22 Posts
Discussion Starter #9
problem fixed! it was the cause of a bad primer. the primer was letting the carbs suck some extra fuel through, put a new one on and it runs like a charm.
 
1 - 9 of 9 Posts
Top