Snowmobile Fanatics banner

1 - 2 of 2 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
Hello it's been a while since I have been stumped. Not that I am such a good mechanic but rather my sleds have just been working great.

I have a 2011 pro rmk 800 that I ran all winter and it didn't have any problems really. My kids had been using it mostly so i dont know when it started losing rpm.
Well I was testing it in my garage with the track off the ground and it wont hold wot rpms. If I blip the throttle it will hit 8200 rpm but if I hold it down all the way, it drops back to around 7000 give or take 300 rpm. If I hold it down it will pulse up to 8200 every 4 seconds or so and then drop down to 7000.

Here is what i have tried so far.
1)new fuel filter
2)Switched secondary from my 2015
3) switched primary and secondary from my 2015
4) new bellows and cleaned exhaust valves
5) disconnected and plugged ves tube that goes to solenoid.
6) tested fuel pressure and it is pretty solid at 55 psi
7) set tps. It was at .716 now set to .7 and then set idle to .945 which is causing it to idle a little high but I will adj that later.
8) new spark plugs
9) cut and re attached plug wires
10) new belt

The last thing I can think of is my injectors are dirty or faulty. It has never thrown any codes.

I have a solid 2015 to swap parts off of.

I'm getting frustrated and want to figure this out before I put it away.

Thanks for any help
Jeff
 
1 - 2 of 2 Posts
Top