Snowmobile Fanatics banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi Guys,


Hoping someone can point me in the right direction on a problem Im having with my 600 Pro-X. I've had the bike for about a year, and since I have had it, there has always been a leaking gas isssue under the sled, after I park it. This seemed to get really bad just on my last ride...the fuel drip seemed to get worse. Also, I just chnaged the rings in the top end, and had everything cleaned out and put back together. Well, rode the sled for about an hour without any issues at all, and was really running the best I've ever seen it. I took a break with my buddies and the bike just died at an idle as we were stopping for a little break. There was spark to the plugs, and they were actually really wet and smelled of gas. After trying to get it going for about 10 minutes, I noticed that it seemed the whole motor has been filled with gas, and it was leaking /blowing gas out of the exhaust pipe as well.

I was thinkning along the lines of a bad fuel pump, or float stuck, as it seemed like that would be some of the things that would cause the motor to jsut get loaded up with fuel like that. Im pretty new to the snowmobile world, so hoping someone may have an idea for me. I'd really appreciate any info you can shoot my way.


Thank you
 

·
Registered
Joined
·
1,377 Posts
Its a needle and seat issue, that is what allows the gas to flow into the carbs. It should stop when your bowl is full. Your needle and seat are either dirty or worn out. Take the cabs off and clean the,.
 
1 - 3 of 3 Posts
Top