Snowmobile Fanatics banner

1 - 4 of 4 Posts

·
Registered
Joined
·
474 Posts
Discussion Starter #1
I have a problem with my 89 Phazer. It will start and it will run normally for a while. After a while, it will not move. It will Start no problem, it will idle but it has no power. After it sits and cools for a while, it will run for a while then have the same problem. The ignition/ spark coil was replaced as this has been a problem with other phazers, but the problem with this one still exists. I'm thinking the problem is the source coil. Can someone tell me what colours are there for each wire coming out of the magneto and what coil they're for ( source, lighting etc.) I do not have a phazer shop manual but I do have an exciter one. Does anyone know if the wires are the same colours and if the readings for the coils are the same? Thanks, Ryan
 

·
Registered
Joined
·
474 Posts
Discussion Starter #2
Once again I've never had this problem, the dealer doesn't know either, but i've got it down to either the CDI or the source coil. Anyone replaced either? Sled only has 15 000 km on it, but its like new. ANy help would be appreciated. Ryan
 

·
Registered
Joined
·
193 Posts
Yeah, my polaris had a similar issue....It was the jokes out of adjustment, when its cold to warm it will run OK rich from the choke but once it gets hot the plugs foul up and theres no power and it eventually died. I believe there was a simple measurement right at the choke knob...1/4" of free play for the polaris anyway.
 

·
Registered
Joined
·
474 Posts
Discussion Starter #4
I haven't checked the choke, but i don't believe it is a fuel problem. I've been over the carbs and cleaned them probably 3 times now. I've got it down to the CDI and Source coil. I'm trying to get my hands on a CDI to borrow one so I can just swap them to see what happens. The sled ran mint all yesterday and I can't get the problem to come back now. I'm waiting for it to die again. I guess it wouldn't hurt to re adjust everything in the carbs though. Any other ideas anyone? Thanks
 
1 - 4 of 4 Posts
Top