Snowmobile Fanatics banner

1 - 20 of 32 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
The carb seems to not be getting any gas at all. I have used this snowmobile every year (well, my dad has), and it worked fine last year. The gas makes it to the carb, but does not go up in it, even when throttle is given. I rebuilt the carb last year, and it ran fine, and now this? What is wrong? Thanks.
 

·
Registered
Joined
·
81 Posts
Well, Taking all my experience so far. I have some knowledge. I am sure the rest of the guys will correct me if I am wrong.

You will need to try a few things to make sure its just your carb.

Take a spark plug out and lay it on the top near where you took it out, make sure the end has a spot to touch or near touch a piece of metal on the engine. Do you see a bluish spark. This means you have spark.

Next: Take out a spark plug and Try putting about 2 tablespoons of gas (REmember to use some mixed gas because your putting directly into the engine). Put the spark plug back on and do the same for the other spark plug (s) depending on how many you have but I suspect on your engine you wont have more than 2.

Once the plugs are back on, give her a pull. She should start up, and heres where you find out if its your engine or possibly your carb. If it starts up and then runs for a bit and stops, and you cant start her back up again and keep her running, then its a good chance you have gummed up needles in your carb.

If you check thru some of the previous posts, some guys have posted steps to cleaning a carb, and I have posted a bunch of links to the various sites offering help to carb cleaning.

Clean your carb real good, taking note to where your lines and stuff all go. DON'T lose any parts and then try again.

Hopefully this information helps you. Again Im not an expert but I am quickly gaining knowledge. He guys, how was my steps to check out his machine. Did I explain everything correctly and stuff. Feedback on how I did would be greatly appreciated so I know if im learning something from this forum.

Cheers

Giger
 

·
Registered
Joined
·
63 Posts
By God i think he's got it.Gigerous "the Sledhead" said it best. After you try what he has explained are you sure that the carb is getting fuel to the foat bowl? Or does that carb use diaphrams?

Vmaxyam
 

·
Registered
Joined
·
948 Posts
Excellent summary Giger!!

If you find the sled runs momentarily then dies, you may also want to check the float level and condition in the bowls of the carb (assuming Mikuni not Tillotson) and also if the fuel pump is delivering any fuel from the tank.

You can check your pump by taking the line off the carb and pulling a few times (easier with the plugs out) and see if you are getting any fuel through that line. If not you may have a bad pump diaphram and/or a bad engine vacuum pulse.

Or it could just be a blockage in the tank. Sled that year could have picked up loads of crap in the tank over the years. Just a few other things to try anyway.

If you have a Tillotson carb, you're on your own!! (from experience)

Let us know how it goes!

-----------------------------
I think.... therefore I sled
-----------------------------
Two '94 Indy XLT SKS
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
If this helps any, the carb uses diaphragms and is a Keihin carb. Could it be something a matter with the pin float? Finally, after some work, too much gas ran through the carb, the snowmobile started, then died--it would not take any throttle. What should I do now? Thanks.
 

·
Registered
Joined
·
69 Posts
<BLOCKQUOTE id=quote><font size=1 face="Verdana, Arial, Helvetica" id=quote>quote:<hr height=1 noshade id=quote> Finally, after some work, too much gas ran through the carb, the snowmobile started, then died--it would not take any throttle.[/quote]
If you are getting gas now and your plugs keep getting wet, I would check out your points. My repair manual list a '78 as the last year for pionts on that engine,
Point gap: .012 - .016

If that don't work, some times when these older engines don't like to be throttled the crankshaft seals are cracked or worn out. They suck air through the seals and only run well at high RPM's. (when they start!)




Edited by - firepinto on January 11 2002 6:01:45 PM
 

·
Registered
Joined
·
63 Posts
I think we all need more information have you change the plugs?Is the fuel in it new? you sure there are no pin holes in diaphram. are the air screws set to spec?what all have yoou tried thus far?

Vmaxyam
 

·
Registered
Joined
·
49 Posts
i think its your crankshaft seal..i have a 89 exciter that had a crack in it from a broken belt that got wrapped up in it. It wouldn't idle and it would idle very high if i poured gas in the carb at first then die out...i bet thats your prob
 

·
Registered
Joined
·
25 Posts
Discussion Starter #12
I can get the thing running now after taking the carb apart and putting it back together after cleaning, but when given throttle, it dies! Any more things to try? Thanks.
 

·
Registered
Joined
·
63 Posts
it very well could be the float if there is in fact one. In answer to your question i have been wrenching on sleds for the past.............well i feel old now. But i need to know what you have checked so for to be of any help and give the model # of the carb so i can look it up I cant remeber if there was a float at all in the carb. To tell you the truth the only way it could be the float is if it was sticking the up position allowing no fuel to enter the bowl or the passage was blocked. Like i said i need to know what you have checked so far then i can give you some advice.

Vmaxyam
 

·
Registered
Joined
·
63 Posts
however your fuel is regulated is your problem at least that is where i would start.when you hit the gas the fuel that was stored temporarlly in the carb is used up and cant be replaced quick enough. If that is not we can trouble shoot further but i bet this is half you battle.

Vmaxyam
 

·
Registered
Joined
·
69 Posts
If his carburator is stock, it would be a Keihin CDX32. Which looks to be a Diaphragm type. Might want to check that your vacume pulse line isn't leaking or plugged. One way to check to see if your engine will even throttle up is to fill up an old spray bottle with gas/oil mix and spray it into the carb (as fast as you can) as you open the throttle. If it does then you can narrow it down to the carb.

 

·
Registered
Joined
·
25 Posts
Discussion Starter #16
Only two lines hook to the carb, and oil line and a gas line. The diaphragms are new as I just rebuilt the carb completely last year, and it worked last season. I checked again and could not find any holes. The smark plug is now only getting oil to it. Gas goes to the bottom part of the carb, about half way up, then stops, thus no gas gets to the top part of the carb. On the carb diagram sheet it says the carb is Keihin, and there are a couple of numbers: QC03 and 8G501, does that help any?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #17
There is a vacuum line hooked up besides the gas line on the carb also. Sorry I forgot to include that.
 

·
Registered
Joined
·
38 Posts
Have you checked you high speed jet? I was having a problem with my sled where it would not wind out and the timing was way retarded so we fixed it i havent ran it yet tho cause i needed to rpelce the rings hopw this help l8r.

 

·
Registered
Joined
·
63 Posts
Try what firepinto has explained and let us know what happens in the meantime I will pull up a diagram of your carb.

Vmaxyam
 
1 - 20 of 32 Posts
Top