Snowmobile Fanatics banner

1 - 8 of 8 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I am hoping to put an '01 mxz x 440 motor in my '97 formula Z chassis (s chassis) Can anyone help me out in terms of it being possible. If so, what things need to be done or changed in order to make it work. Also, there is an oil block off on the bottom of the motor and I was wondering if it can be converted to oil injection. Replies to this as soon as possible would be appreciated.
Thanks
 

·
Registered
Joined
·
25 Posts
the motor mount are gonna be different so take the motor mount off Ur s chassis motor mount n make new hole we the 440 hole on the engine are
 

·
Registered
Joined
·
2,304 Posts
It is possible, but would be a big job, and I don't think you will fit it all under the hood. Since The S chasie is an original RV engine and you will be going to a reed valve engine, so the will sit in different positions and things like a belt may be hard to fit
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
a buddy of mine who worls at a Ski Doo dealership said the motor should mount in fine, he just didn't know about the air box and how it would sit with the carbs
 

·
Registered
Joined
·
86 Posts
I didn't see this post before i saw the one with the vid.

Yes the carbs are gonna sit a few inches higher then the RV motors carbs will. Possibly an airbox from a zx chassis sled will work. It shouldnt be a hard swap, generally because that 440 motor will have mounts on the bottom of the case to run a S-chassis motor plate, and it was already a liquid cooled sled.

When i did my swap i went from a 500 fan to my 617, i had to put the heat exchangers in the tunnel, i made my own airbox out of stainless sheet metal, and the exhaust dropped right in, the coolant tank bolted right up.

It shuoldnt be a hard swap.
 

·
Registered
Joined
·
86 Posts
Also one more thing, look up all the stock clutch specs for a LC 440 MXZ and set your clutches to that for starters.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
well i got the 583 motor out and all I have to do to mount the 440 on the 583 plate is drill new holes 3/4 of an inch over so the primary clutch lines up with the secondary, the secondary from the 440 wont fit on so i'm going to have to run the 583 secondary, will this be a problem? also i'm now just trying to deal with the wiring mess
 
1 - 8 of 8 Posts
Top