Snowmobile Fanatics banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Just purchased a 2002 Polaris 600 Edge XC with Fox Suspension and approximately 3600 miles. The sled was last used in 2011 however, it does start on the 2nd pull. I paid 400 for the sled so I didn't take a very through look before purchasing. What are the first things I should check? The model number is worn off the data tag however the VIN is still very easy to read. Is there anywhere I can reference parts and manuals by the VIN? Thanks in advance for any help.
 

·
Registered
Joined
·
13 Posts
Check both the power valve bellows......likely need to be replaced. Also check the brackets in the footwells that the trailing arms attach to. They are notorious for cracking and letting loose (I know from personal experience).

Good luck
 

·
Registered
Joined
·
10 Posts
if it runs just put in fresh gas and oil and ride it to see what it does or doesn't do. you may be lucky- add a little oil to the gas the first tank. the only thing bad is if they sit and the carbs get gunky from sitting gas. worst case is to take off carbs and clean. oil and lube everything. you can find manuals online usually for free. I also have a 2003 classic 700 and bought a used manual on ebay for $25.
 

·
Registered
Joined
·
1,236 Posts
Just revived a 440 been sitting since 11'. Little oil in the holes to make sure walls were lubed few pulls some fresh gas, runs like a rapes ape

Sent from my XT1650 using Tapatalk
 
1 - 4 of 4 Posts
Top