Snowmobile Fanatics banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 92 rxl efi that has just been rebuilt. Everything runs great for the first 20 miles then it throws itself into fail safe and boggs down. At this point the heads are hot to touch, but the computer isn't spitting out any codes and the temp. light is not coming on. The coolant is not hot and when I took off the cap to bleed the system the heads seemed to cool off.....ghosts in the machine any help?

My other ride is your mom!
 

·
Registered
Joined
·
48 Posts
This is just a guess here.... but since it has just been rebuilt, There is as possibilty of air in the cooling system. It sounds like that could be causing your problem.

I think its Snowing!!
1999 Polaris XCR 440
 

·
Registered
Joined
·
149 Posts
Sled Jed let me know what you find. I am having a similar problem. I also just have an RXL that I rebuilt. I kept getting a little bog but I thought that was the normal RXL bog that everybody talks about. I was overheating. The temp light was coming on though. Then i was cruising down the trail the next week and boom! blew a piston. I kept checking the computer but no signal. Wish I knew what it was... pissed me off cuz that was the first ride with my new 136x1.75 track on it

I need spellcheck!

91 RXL/SKS 650
91 Exciter II 570
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
snorider I'll keep you posted. I think it is an air pocket but I have burped it twice with the same results. If it is an air lock it's a stubborn one. I check the heads for temp. every two miles or so and its good then all of a sudden the bogg and right to hot. Well all I can do is illiminate the simple and hope its not serious I dont want to rip this thing apart again.

My other ride is your mom!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
hot rod, i was seeing this as the exact opposite. the heads would get hot, then the bog was the fail safe. the computer would throw more fuel and oil into the jugs, producing a fat condition to save the engine. i'll check it though
 

·
Registered
Joined
·
149 Posts
Looking at my piston I'd say for sure that it was lean. I'm gonna check that crank seal first. My polaris dealer agreed. I'm gonn try to switch it over to carbs this sumer.

I need spellcheck!

91 RXL/SKS 650
91 Exciter II 570
 
1 - 7 of 7 Posts
Top