Snowmobile Fanatics banner

1 - 5 of 5 Posts

·
Registered
Joined
·
580 Posts
Discussion Starter · #1 ·
anyone have a secondary for a 97 spx? looking for a complete swap to test something. Not looking to spend a fortune because i could just replace all the pieces. Have a clutching issue that im not sure about......

sled is squealing at a stop unless you touch the brake before stopping. primary seems to be shifting allright. belt seems to pull down into secondary. brand new belt. never blows the belt!!!!
 

·
Registered
Joined
·
2,731 Posts
With a new belt, I bet your sheave width is too tight.
you can widen it a bit by turning that gold color disk on the end of the secondary down from a 3 or 5 to position 1
 

·
Registered
Joined
·
9,987 Posts
Did you clean the belt before installation? A green scrubbie and a sink full of dish water will remove the coating on the belt.

Also clean the clutches, and rough them up with some 120 to 220 grit sand paper.
 

·
Registered
Joined
·
580 Posts
Discussion Starter · #4 ·
i will try both these suggestions. as soon as i get my stepfathers classic600 off my table. chaincase/driveshaft rebuild. still gotta finish up gears(w/ reverse) and put m-10 back in after some new track clips and 2 new idlers..
 

·
Registered
Joined
·
320 Posts
Mine started doing this last season with a bad jackshaft bearing. Replaced that to find the old bearing ate through the jackshaft. And then replaced that this year. But also had signs of crappy acceleration and shift out would not happen. So best of luck. And hope it is a cheap fix.
 
1 - 5 of 5 Posts
Top