Snowmobile Fanatics banner

1 - 9 of 9 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Hey everyone
My 1979 ski-doo everest 340 wont start. I was running about 2 months ago. I have checked the cylinders pistons replaced the tings, cleaned carbs and adjusted them replaced plugs cleaned the points( thinknig about buying new condensors and points. I am stumped as to what is wrong. we have adjusted the timing as well. even tried using either to start it and it didnt go. it was running pretty good for a while then it stopped winding past the midrange. Anyone have an idea as to what is wrong? The plugs spark well to. I have tried putting a little gas in the cylinders.

 

·
Registered
Joined
·
13 Posts
There are three things that make ALL enternal combustion engines run.
1. fuel , 2. Compression and 3. Ignition. ( in proper sequence of course) ). As you have ignition (assume timeing is somewhat correct), and you manually feed it fuel(starting fluid) , I suggest you you check the compression. If you have good compression and feed it fuel you probably have the ignition out of sync. Waiting to hear how she goes. Smith
 

·
Registered
Joined
·
38 Posts
Discussion Starter #4
I have compression tested it it has new rings so the compression is pretty good fro an old engine its at about 125-30 maybe more my compression test isnt hat accurate because its not one with threads. What do you mean the ignition is out of sync do you mean timing?

 

·
Registered
Joined
·
2,729 Posts
Well you say that you have compression, spark, and fuel. So i guess what i wanna know is, does it backfire, or try to start? What happened when you put fuel in the cylinder????? Also, when you cleaned the points, were they still in specs??? We will get to the bottom of this.

Polaris is my way out - Other people just use a door.
 

·
Registered
Joined
·
167 Posts
if you have compression and you have fuel then it should run, do you have spark?, lay your plug against the head and pull it through it should spark a series of bright blue sparks, if not id suspect the coil, or electronics, make sure your kill switch or key isnt grounded and causing you a no spark, id say no to the timing being off unless you had it apart because they usally put thread locker on the screws, check for fuel and spark and let us know

if its not a CAT, then it must be a dog!
 

·
Registered
Joined
·
38 Posts
Discussion Starter #7
I have spark and a good spark. When i put fuel in the cylinder nothing really hap-ened. they is no backfiring. A couple of times it sounded like the sled wanted to start but it didnt. We are gonna check the airscrew mixture and take the carb apart again. One of the points was way of timing and the other wasnt as bad. Thanks

 

·
Registered
Joined
·
13 Posts
If this is a Type 343, 340 cc engine. it has two ignition systems. One for each cylinder with ignition taking place ONLY on the compression stroke, (Not both top and bottom dead center like some two stroke twins) If the coil wires have been replaced, maybee the long wire actually goes on the near cylinder. ( try changeing the plug wire location). Hey I,m not nuts, had a 77 TNT RV that this happened to me. It was a used sled and I didn't notice the diff when I jerked of the wires. Good luck, Smith
 

·
Registered
Joined
·
2 Posts
i have a 77 ski doo olimpique 340, i had a problem and couldnt get spark on one side, i pulled the ignition system, rewired everything filed the points and tested everything and found out it was the condensor, after i replaced it i put everything back together, and nothing in either cylinder, i found out that i had adjusted the points way to far and they werent opening so i adjusted them and bingo it fired on one pull, i advanced them a little for shits a giggles, and it has more acceleration now, so check your condensors and i hope you get it running have fun
 
1 - 9 of 9 Posts
Top