Snowmobile Fanatics banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey, i have a 1973 sno jet SST 295. I just put new points in it and it sparks great. I also just put a new carb kit in it b/c the fuel pump diaphram wasnt working. It does kind of run but not for long, i am getting fuel to the engine, but it wont run for more then 1-2 mins without fouling, and it also wont rev up high enough to engauge the clutch it just bogs down wen i hit the gas. I had the carb set up with the right settings for the high and low speed, but that didnt seem to help the problem, i tired playing with the settings and still no luck.I'm currently running 32:1 in the tank and am wondering if my problem could be as simple as changing the mixture to 50:1 or if its more complex?
 

·
Registered
Joined
·
1,428 Posts
nope, i always ran 32:1 in my jets, adjust your carb, the T screw is the top end screw, if you turn them both all the way in, they should turn out 1 1/2 to 2 turns out
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
alright thanks, i'll try playing with the high speed and low speed again, i wish the damn thing was electric start i've pulled this thing over and changed/ cleaned the plugs more times than it seems like its worth.
 

·
Registered
Joined
·
2,505 Posts
Weak or no spark in one of the plugs. possibly a coil.
 

·
Registered
Joined
·
288 Posts
check the pulse line, also check that there are no air bubbles in the gas line, or an air leak that causes tiny bubbles to run through the line.
 
1 - 5 of 5 Posts
Top