Snowmobile Fanatics banner

1 - 12 of 12 Posts

·
Registered
Joined
·
2,307 Posts
Discussion Starter #1
Well, just got back yesterday from the trip from hell. Let's see...........got up to the Haven Inn on the Loring Airforce Base at around 11:30 Sat morning, unloaded, checked in and went out to ride. Got all of about 4 miles on and guess what........pto pisto goes POP!

Ended up bringing it to a place called Richie's Snowmobile off of Rt 89 heading north out of Caribou. All I can say is great place and great people. He had the engine rebuilt and ready to go by 7:30 that evening! I highly recomend the place if your ever in that area with sled troubles.

Anyways I plan to ride on Sun. We head out and I start fouling plugs. So I pick up a case of them (10 in a case). Over the course of the day end up using all of them plus two more from my brother. At first we thought that maybe the pre-mix gas was too rich. But I burnt that down and refilled the tank twice. It was better, but still fouled them.

Made it home that night and planned on checking the carbs out myself Mon moring. I told everyone else to go on without me. I found the choke cables weren't closing all the way, so I adjusted them, and put on about 8 miles without any problems. So I figure I'm all set and plan on riding Tues. Head out Tues moring and fouled three plugs in about 5 miles. So I said [email protected]#ck this, I'm heading back.

It only seems to foul them when I've been going 3/4 to wide open for extended periods of time. Which is most of the time up there. So now that I'm back I'm going to pull all the carbs and check them over real well. I'm sure its something minor. Also will be checking the fuel pump and the coils as well.

To make a long story short.........I WILL be snow checking a new sled this spring.....end of story! I'm not going through this sh!t again. Spend all that time and money to sit in a damn hotel room to watch TV. I was and still am bullsh!t about the whole situation.
 

·
Registered
Joined
·
2,307 Posts
Discussion Starter #3
Aroostook county in northern Maine. About a 5 hr drive from where I'm at. They've got more snow up there than I've seen in a long time....10-15 foot snowbanks.
 

·
Registered
Joined
·
975 Posts
Man that really sucks Tfin. You just put in new springs in the clutch and everything too didn't ya? Man.....better luck next time.
 

·
Registered
Joined
·
103 Posts
Sorry to hear that man...
 

·
Registered
Joined
·
11,943 Posts
Yeah, thats what sleds can do to ya sometimes. It really sucks. Sorry to hear about the bad bit of luck you have been having.
 

·
Registered
Joined
·
749 Posts
Probobly shouldn't be runnin full throttle for extended periods of time after a rebuild. But that shop sounds like a good place. To bad your trip got ruined. Went up to tobique valley new brunswick a week ago and put on 300 miles. It was an awesome trip. Only trouble was my girlfriend ran inot me and broke her tail light and broke both of our bumpers. We were ridin 2000 zl 500 liquids.
 

·
Registered
Joined
·
837 Posts
he t did the shop do anything to correct the problem with the piston, there is usually a reason they burn down, just putting a new set of pistons it won't fix it, did they give any sugestions to the root problem
 

·
Registered
Joined
·
2,307 Posts
Discussion Starter #10
Yeah, come to find out the base gasket was faulty. Was leaking air into the pto side. New head and base gasket as well as piston and rings. Only thing I didn't understand (and forgot to ask at the time) was why the plug color on that side still looked ok. It was a nice cardboard tan....just like it was suppose to be. Any time I've ever seen a piston pop from an air leak, it was white.
 

·
Registered
Joined
·
1,039 Posts
All I can say is I feel for ya man. All that time and preparation for nothing, at least I got 200 miles out of mine on my big trip before I had to leave it in the woods. I'm going to give my XLT one more chance and that's it.
 
1 - 12 of 12 Posts
Top