Snowmobile Fanatics banner

1 - 11 of 11 Posts

·
Registered
Joined
·
482 Posts
Discussion Starter #1
Guys, my sled keeps wrecking the spedometer key's, the little spun wire type. The bearing is brand new as of end of last year, but it has spun out 2 keys.

I'm thinking the problem is either with the shaft being worn too small from the guy i bought it from who rode it 300 miles on a bad bearing, or that there is excessive drag in the speedometer, the cable or the drive adapter.

I'm going to have to drill this one out because its really in there and really messed up.

Has anyone ever tried using a solid bar-stock key? These crappy spun wire ones keep breaking. Or should i just drill it out again and hope for the best?
 

·
Registered
Joined
·
4,755 Posts
might want to try to lube the speedo cable ,it might be the problem
 

·
Registered
Joined
·
764 Posts
you could try a solid key, all that would happen would be the speedo cable would bust if it cant turn it
 

·
Registered
Joined
·
1,145 Posts
try cleaning the cup housing that holds the pin in place. once you do this, than check into your cable not spinning freely. good luck
 

·
Registered
Joined
·
482 Posts
Discussion Starter #5
its looking more like the speedo, the cable, or the adapter is f'd up. I tried turning the speedo and cable with a new key, with the adapter unbolted, and i couldnt turn it either way by hand, and normally i could. then i tried taking the cable off the adapter, and its like stuck in there. but since it started getting dark, it will wait til tomorrow. I want to be patient and try to get it apart without wrecking the cable too.
 

·
Registered
Joined
·
527 Posts
I had the same problem, instead of replacing it with another stock key I just took a hex wrench and cut it to fit. I works great no problems what so ever. I looked at all the bearings and checked the shaft and there was nothing that would cause further damage when I put the hex wrench in.
 

·
Registered
Joined
·
482 Posts
Discussion Starter #7
good thinking. i think my adapter is jammed. when it snows i will drive it around to the garage and take care of things.
 

·
Registered
Joined
·
482 Posts
Discussion Starter #8
well i got my 3/32nd cobalt drill bit today so the only thing left to do is free up the adapter or get a new one, and drill out the old key.
 

·
Registered
Joined
·
12 Posts
Had the same problem with a 93 wildcat.It would break off every time sled was put into reverse.Ended up being the speedo drive unit.It was binding in the oppisite direction.
 

·
Registered
Joined
·
527 Posts
Mine doen't have reverse on it. Was that an option for you or did it come stock on the 93?
 
1 - 11 of 11 Posts
Top