Snowmobile Fanatics banner

161 - 166 of 166 Posts

·
Registered
Joined
·
411 Posts
Discussion Starter #162
Sorry guys. I haven't checked this in a few days. I will be getting the Storm back up and running again tomarrow. I worked on it all night tonight and all I have to do is get the pipes back on. When I put the motor back together this time I decided to run just a single head gasket. I haven't checked the compression yet but it sure seems to pull over alot harder now. We'll find out this weekend how it runs out on the lake.[thumb]
 

·
Registered
Joined
·
32 Posts
yellowstorm, when you have a chance I would like to know what you end up with for compression psi with the single gaskets, I picked up a single set but have not swapped them in yet.
 

·
Registered
Joined
·
411 Posts
Discussion Starter #165
PAStorm said:
I would like to try the HPE orange/black spring, yellowstorm, would you be interested in selling the one you have?
I would probably sell my HPE spring but I will have to find it first. I have a brand new one and a slightly used one. I will look tonight for them. The engagement on my Storm with that spring was very high. It was around 6,500 rpm.
I haven't checked the compression yet but I know it has a little more power now. I was running 10-56 weights before turning 8700 rpm and now I am running the same rpm with 10-58's. I am deffinitely going to gear the sled up though. The sled tops out at 107mph and then it starts over revving to 9,000 to 9,200rpm. I think I will try stock gearing and with either the 58's or 60's.
 

·
Registered
Joined
·
6 Posts
Is this thread going to be allowed to die? This is by far the best storm thread out there, any of you guys still active I need information haha, legendary threads never die and real motors dont need exhaust valves🤣
 
161 - 166 of 166 Posts
Top