Snowmobile Fanatics banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hows it goin guys. Hopefully someone on hear can give me some insite on this bog issue. 94 polaris 580 engine that always had a bog even when it was stock. Put triple slp pipes on it jetted and clutched to spec and still had the bog. Rebuilt the engine new crank seals new pistons rings gaskets new 38mm carbs jetted to slp's spec and had them port it out. Now what it does is bog off idle. if you snap the throttle all the way it will bog then take off. sled runs perfect through the whole rpm range after that. tried adjusting air screws does nothing lowered needle clip does nothing. rebuilt fuel pump no luck. checked floats too. at at my ends with this thing any ideas? Matt
 

·
Registered
Joined
·
9,987 Posts
Check the primary clutch..

A weak spring will let the clutch engage before the motor can get the revs up into the power band.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
clutch engages at 4500rpm. just rebuilt the clutch. it cleans itself up before enngagemenr. Think the 45 pilots slp recomended are to big?
 

·
Registered
Joined
·
378 Posts
I would look in to dial a jet. What they do is add fuel to the carbs. You lean out the carbs 2-3 sizes smaller than what you are running and then it adds fuel in front of the slid to make the right air/fuel ratio for the motor from idle to WOT. This will take any fuel issue that you might be having out. Another thing is that you might have a air leak in the motor. When it is running spray carb cleaner around the motor seals. The major seal is the crank seal behind the clutch. Hope that this helps you out in your issues.
 

·
Registered
Joined
·
632 Posts
sounds like dirty pilots.
 

·
Registered
Joined
·
118 Posts
xcr580 said:
clutch engages at 4500rpm. just rebuilt the clutch. it cleans itself up before enngagemenr. Think the 45 pilots slp recomended are to big?
WOW ya #45 pilots are wa to big. drop to #30 they will be great[thumb] But also check your secondary spring to it could be weak
 

·
Registered
Joined
·
1,458 Posts
xcr580 said:
clutch engages at 4500rpm. just rebuilt the clutch. it cleans itself up before enngagemenr. Think the 45 pilots slp recomended are to big?
Pilots seemlike a good place to start. I know SLPs jetting specs are a little on the safe/rich side. Worth a try to drop a size, just remember to check your plugs a few times just to be sure.
 

·
Registered
Joined
·
2,223 Posts
The 96 XLT SP I owned a few years back behaved the same way. I tried all of what you have done other than the pipes and I couldn"t rid myself of the inherent initial bog. Ran like a top other than that.
 

·
Registered
Joined
·
1,378 Posts
xcr580 said:
Hows it goin guys. Hopefully someone on hear can give me some insite on this bog issue. 94 polaris 580 engine that always had a bog even when it was stock. Put triple slp pipes on it jetted and clutched to spec and still had the bog. Rebuilt the engine new crank seals new pistons rings gaskets new[highlight=yellow] 38mm carbs [/highlight=yellow]jetted to slp's spec and had them port it out. Now what it does is bog off idle. if you snap the throttle all the way it will bog then take off. sled runs perfect through the whole rpm range after that. tried adjusting air screws does nothing lowered needle clip does nothing. rebuilt fuel pump no luck. checked floats too. at at my ends with this thing any ideas? Matt
94 XLTs or the 580s in general did not come with 38s they were 34s. My guess is when you hit the throttle your dumping a boat load of gas in it and then it clears it's self out. I ran SLPs on a 95 XLT SP And if your intrested when I get back from class I give ya the carb combo.[thumb]
 
1 - 10 of 10 Posts
Top