Snowmobile Fanatics banner

1 - 14 of 14 Posts

·
Registered
Joined
·
695 Posts
Discussion Starter · #1 ·
So last week my kids track finaly went to hell on his 99 ZL. We found a used track from a friend for free just to get him through this last month of riding. Its a pretty well worn 1 inch track with alot of lugs missing but still usable. Anyways not more than 30 miles since we installed it the front side of one of the rails catches the track and tears it. Track is definletly shot now(ripped). Luckly he had just crossed a road and wasnt going very fast cuz it stopped him like right now. Any ideas what would cause something like this? The track tension is where it is supposed to be. Thanks
 

·
Registered
Joined
·
4,331 Posts
broken limiter straps?
 

·
Registered
Joined
·
2,585 Posts
Yes this is almost definitly limter straps. Happened to my mach z.
 

·
Registered
Joined
·
695 Posts
Discussion Starter · #4 ·
Ok, i looked at the limiter straps. They are both intact and look good, defineitly different than polaris' setup. I see they are adjustable by the tighting of a nut. I still dont see how if they are still good how this could happen. Maybe i might tighten up a little bit before i actually put a good track on...jesus i just cringe when i think if that would of been a brand new track, thats why i wana make damn sure i know what happend and why before i put a new one on for next year.
 

·
Registered
Joined
·
2,585 Posts
They could be too loose. Otherwise, maybe track isnt tight?
 

·
Registered
Joined
·
695 Posts
Discussion Starter · #6 ·
Track tension is the first thing i checked where it stopped at and was plenty tight. Their is alot of room for tighting on the straps. Maybe i might find more once i tear into it but everything from where i can see now looks good.
 

·
Registered
Joined
·
2,585 Posts
Did the rails or sliders somehow catch? just theorizing.
 

·
Registered
Joined
·
171 Posts
What does the black peace at the front of the rail look like? I had a broken one once and I didn't know it.. rail went right through track window. Also, If that was really worn, the track might catch on the rail/slide. Idk, can't you tell by lookin at it. Also, isn't it kinda prosses of ilimination? That would be the first thing I would look at, not the limiter straps. If that peace was ok, than its the slides, if the slides are ok, than maybe the limiter strapes. Limiter strapes would not be the first thing I would look at. If the limiter strapes were that loose, I don't see how that would tear the track up. One thing I have learned on this site is that people look to deep to qiuck.
 

·
Registered
Joined
·
695 Posts
Discussion Starter · #9 ·
The rubber boots look good in front of the rails, the slides are getting where they could be replaced but still ok. I will definetly be replacing boots and slides tho before i install the new track. Anyways the season is over for this sled, probally wont get a different track til later this year so ill go threw everthing thouraly when i get it torn appart. And so what if im looking "to deep to quick," dont answer me then and move on. Just seein if their is a significant cause for this problem since i wont have it fully disemblemed in awhile. Thanks for the replies
 

·
Registered
Joined
·
171 Posts
I wasn't saying you were lookin to deep... sorry. I ment sum of the other peoples quotes. I would have to say that about 95% of the time its cause sumthin is wrong at the tip of the rail. Not saying freak things can't happen, but if it was just a broken or loose limiter strap that caused it, don't you think it would happen more often just for the hell of it? I know there would be more pressure on the track if it was broke, but what are the chances if the tip of the rail was good that it would go throught the track? When I broke the black peice at the end of the rail on my sled and put it through the track, I still rode it about 20 miles and it was broke to a point. Lucky I guess. I understand you were jus doing what the other people were saying. Did you figure out the problem then, or was the track just that rotten?
 

·
Registered
Joined
·
695 Posts
Discussion Starter · #11 ·
Think i found the problem. When the first track went to hell it took a boot along with it. So my son and his cousin robbed one off a different sled(not the same one.) The one they put on is a little shorter and fatter than the longer and narrowor one that should be on their. It really doesnt look like it would catch but i would say thats gotta be the reason.
 

·
Registered
Joined
·
844 Posts
Might also check and see where the front of the skid is mounted.
Top hole, bottom hole. This by itself wouldn't cause the problem,
but may have been a contributing factor.
 
1 - 14 of 14 Posts
Top