Snowmobile Fanatics banner

1 - 16 of 16 Posts

·
Registered
Joined
·
313 Posts
Discussion Starter #1
Has any one used these UFO's and if so did you find them near to impossible to tune. I'm killing myself trying to get my sled to idle with them installed.... I've followed the factory instructions to the letter but cannot get the thing to idle. (1991 Formula MX 470 w/.040 overbore and milled head)- stock exhaust... Any Ideas/help would be great..... Larry[?]

Instructions .... 1)Install UFO's in carb pistons(without problem there) 2)grind piston skirt flush with UFO(also no hitch) 3)Install pilot jet haf size of original (again no problem) 4) Warm up engine and adjust idle(problem is here) The idle ajusts fine then run the sled for a few min on the trail and then that's when it happens ... It starts to run like it kills a plug. If you put in new plugs - it still runs like it has 1 dead plug.(Pull the plug bothe look OK, not wet or black) If I put everything back to normal it runs great. (I NEED TO FIGURE THIS OUT, my wife bought them for me) Any married man will know whai I'm talking about......
 

·
Premium Member
Joined
·
15,513 Posts
HaHaHa. I got those in my sled, It came with them. I havn't had a problem yet, They guy said that They did help some, He definetly noticed. I don't know too much about them, I will ask some buddies.
 

·
Registered
Joined
·
837 Posts
well don't laugh at him, you should got out to you sled and pull the carbs and check the specs, what do you think? i know thats what i would do
 

·
Registered
Joined
·
328 Posts
I had them my summit 500 a few years ago, what a difference! WAY easier to start and a little more top end. I had mine installed at a dealer and never had a problem with it idling. I don't know if this would matter at all, but maybe your idle screw is backing off when your riding? I had that happen on my motorbike, it fell right out. Thats the only thing i can think of.
 

·
Registered
Joined
·
313 Posts
Discussion Starter #6
No, like I said if I take it all back out it runs fine. I get it to idle and warm up after install, but after a few minutes of riding it messes up.... I would get it done by my local dealer but I don't like the work they do...... Not top notch. I'll keep the post going for a while (ufo's) seem to be somewhat popular.
 

·
Premium Member
Joined
·
15,513 Posts
Mattgross, I was laughing at the wife comment. NOT the problem at hand. I am not pulling my carbs off my sled and checking specks. The specs of my mikuni carbs off my cat will probally do him no good. If he asked me to do that. I would. Or I could just get the from my users manual, that would be a heck of alot easier. Larry, keep us informed, repost in this topic with your outcome.
 

·
Registered
Joined
·
313 Posts
Discussion Starter #8
I'll try putting them back in today, maybe with a larger pilot jet 25mm or 30mm, instead of the 20mm. I'll let you know how it turns out....
 

·
Registered
Joined
·
313 Posts
Discussion Starter #9
Just to let you know the weather got too bad to put them in (freezing rain, hail).... I'm not fortunate enough to have a garage.... And my wife said no to putting it in front of the sofa...Hopefully tomorrows weather will be better....
 

·
Registered
Joined
·
8 Posts
I have a set in my 38's and they were a real bitch to tune.I put them in the first year they made them and there wasn't much info on tuning them till the next year.I remember buying three sets of pilot jets just to get it to run.I know that I had to go smaller in the pilot than what they recomended.I also use a 3.0 cut away in the slide.I am in the mountians of BC so my alt. might be the reason I had to use such a small pilot jet
peace...willie
 

·
Registered
Joined
·
313 Posts
Discussion Starter #11
Stock pilots in my 34's are 40mm so I started with 20's (didn't work so well)... I'll keep trying, and see what I can come up with.......
 

·
Registered
Joined
·
8 Posts
I started with 40's in my 38's....ended down at 12.5 or 15 . I can't remember,but I do remember that it was hard to find pilots that small.Every shop I phoned thought that I had lost my mind wanting that small of pilot for an 800 triple.
good luck
willie
 

·
Registered
Joined
·
313 Posts
Discussion Starter #13
Well I got it figured out, only had to install a set of 25's. No bog, no hesitation... Until the rewar drive snaped in two...... Oh well.. Nest to fix......
 

·
Registered
Joined
·
313 Posts
Discussion Starter #16
Yes it's mutch faster. It gained about 10kph on the top end, powerband is smoother, and accelerates harder over all...Rear dribe is 3 idler wheels and the shaft and track adjusters... I'll get new ones from Royal Distributing..... I'll be delivered over night....
 
1 - 16 of 16 Posts
Top