Snowmobile Fanatics banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2,382 Posts
Discussion Starter · #1 ·
Finally thought I had the bugs worked out on my rmk, so I decide Im going to Petersville for a three day trip.. first day, find I have a coolent leak (not sure where, but my coolents goin somewhere..) so I had to ride with a gallon of coolen in my back pack. then sunday morning Im out rippin up some hills and my sled suddenly starts running weird. I stop and open my hood, the engine plate busted [beatup] this is the third one I'v broke (two back when my engine was still in the xc) so that puts the end to my trip, just sat around the cabin till this morning when we all headed home.

This sled pissed me off, Im putting my risers, shocks and engine in my 97 sks [thumb] I'll either part out the rmk or tare it down to a bulkhead and tunnel and start over again this summer.

 

·
Registered
Joined
·
584 Posts
could your crank be a little off center and vibrating the hell outa the engine plate until it snaps?
 

·
Registered
Joined
·
2,382 Posts
Discussion Starter · #3 ·
Well tore the engine out of it. motor mount is riped in half, plate is broken, and my torque stop is toast. I dont know the cause of it.

I'v been using the old style one peace plate, I wonder if I went to the two strap style plates if they would be stronger.
 

·
Registered
Joined
·
2,382 Posts
Discussion Starter · #4 ·
Well I started thinking about it, why would I rob parts off a newer sled for something thats 3 years older... forget that. I took the motor mount from the sks and the torque stop, and found a engine plate in my parts shed!

stripped the paint off the head, I think it looks pretty cool without paint on it. polished my recoil, clutch cover and head... pimpin.. should have the rmk back together tomorrow if I can find the coolent leak.
 

·
Registered
Joined
·
3,212 Posts
crdude said:
Well tore the engine out of it. motor mount is riped in half, plate is broken, and my torque stop is toast. I dont know the cause of it.

I'v been using the old style one peace plate, I wonder if I went to the two strap style plates if they would be stronger.
The pro-x's have the straps and they have a hell of a time breaking mounts on them....On Big block sleds.

There is a guy on HCS that makes a one peice plate for Pro-x machines that has a 5th mount location
 

·
Registered
Joined
·
2,382 Posts
Could there be a hole in your radiator. Another place is by you water pump, the seal on mine whent out last year started loosing coolant until we found that.
 

·
Registered
Joined
·
4,299 Posts
dodger said:
crdude said:
Well tore the engine out of it. motor mount is riped in half, plate is broken, and my torque stop is toast. I dont know the cause of it.

I'v been using the old style one peace plate, I wonder if I went to the two strap style plates if they would be stronger.

The pro-x's have the straps and they have a hell of a time breaking mounts on them....On Big block sleds.

There is a guy on HCS that makes a one peice plate for Pro-x machines that has a 5th mount location

I know Brad(poweraddiction) makes a lot of plates and he'd be the guy to make one for you crdude. Otherwise get the straps and an SLP plate to go across the top to keep the cases from flexing.

kingofkings said:
Could there be a hole in your radiator. Another place is by you water pump, the seal on mine whent out last year started loosing coolant until we found that.
um...RMK's of this era don't have radiators
 
1 - 8 of 8 Posts
Top