Snowmobile Fanatics banner

1 - 5 of 5 Posts

·
Registered
Joined
·
563 Posts
Discussion Starter · #1 ·
2003 440 sno pro. Has about 2000 miles on it. Has not been raced. Belongs to a friend. We tore it down because of a head o ring started leaking. The bore looks like it has no wear. No scuffing on pistons but both pistons have cracked skirts. They are the stock pistons. The only thing I found wrong was the exhaust valves were both stuck closed. Gummed up really bad, we about couldn't even pull them out. Can that cause alot of heat in the combustion chamber?
 

·
Registered
Joined
·
3,130 Posts
More than likely just use. You can't expect the normal rebuild times out of race sleds. Having the powervalves stuck is not good for your engine though. Didn't your friend notice shitty high rpm performance?
 

·
Registered
Joined
·
85 Posts
its a race sled, which means more maintenance, and also good octane fuel, my buddy has an 02 zr 440 which is the samething,whats the timing set at,and how fresh is the gas, we have been seeing a lot of sleds with busted skirts from ethanol fuel that is stale,or has water in it. and he should bave noticed that it was running like sh*t....
 

·
Registered
Joined
·
563 Posts
Discussion Starter · #4 ·
Empire087 said:
More than likely just use. You can't expect the normal rebuild times out of race sleds. Having the powervalves stuck is not good for your engine though. Didn't your friend notice shitty high rpm performance?
well he has been sayin for a while that it doesn't seem to run as good as it did when he first got it. He has been trying differant clutching combos so we just thought we didn't have the clutching right. I assume the stock valves would really kill the top end power


02zr440sp said:
its a race sled, which means more maintenance, and also good octane fuel, my buddy has an 02 zr 440 which is the samething,whats the timing set at,and how fresh is the gas, we have been seeing a lot of sleds with busted skirts from ethanol fuel that is stale,or has water in it. and he should bave noticed that it was running like sh*t....
I think the timing is set on -2 on that little box. The fuel was all fresh. It ran good other than he said it didn't seem to pull like it used to. The stuck valves are probably to blame for that though
 

·
Registered
Joined
·
85 Posts
i dont think so..... but give it a shot
 
1 - 5 of 5 Posts
Top