Snowmobile Fanatics banner
1 - 11 of 11 Posts

·
Registered
Joined
·
191 Posts
Discussion Starter · #1 ·
my sled is makin a wierd noise..it happens when i accelerate.....is it a belt or has somthing seriously gone wrong its my first skidoo so idk whats happend...it still works but it makes that noise
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #3 ·
well its more of like a screaching noise not really clunk clunk clunk
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #5 ·
no i havnt touched it since i got it like 2 weeks ago iv just been riding it alot
 

·
Registered
Joined
·
191 Posts
Discussion Starter · #7 ·
so what do i do..its my first sled so i dont know much
 

·
Registered
Joined
·
137 Posts
The hyfax is the long nylon (plastic) bars that run along the bottom of the rear suspension. The metal clips in the windows of your track run on the hyfax. If they are worn thin, of you can see the rail through the bottom of them, then you need to replace them. They are usually around $10 each. You may be able to slide them out through a window in the track, if not, you will need to remove the rear suspension (skid) and change them that way. Or, bring it to a shop and have them do it... if you remove the skid you will need to readjust the track tension, and that is a whole new thread.
 

·
Registered
Joined
·
6,021 Posts
Hey, is your track studded? If it is, one of the studs may have torn the track. As the track spins, that loose stud will hit and make a "wap-wap-wap-wap" or possibly a scratching sound.
 

·
Registered
Joined
·
2,304 Posts
melt all the snow out of it first (heated shop) and then take it for a run, might just be the trake hitting ice build up
and check all the above also
you can lift the ass end and turn the track to also see were it is coming from
 
1 - 11 of 11 Posts
Top