Snowmobile Fanatics banner

1 - 7 of 7 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
My friend has a 79 arctic cat pantera 5000 with a 500 twin in it. Pretty much it just won't run and has good spark and fuel pressure. If you spray anything down the throat of the carb it will fire immediately. And this carb was just professionally cleaned..bead blasted and float levels set. All plugs epoxyed..pressure tested..and i opened it up again and everything seems right to me and the floats work when i fill it up with gas. Once i got it running with ether which is a no no i understand and kept it running about 3,000 rpm's for a little while i could keep it going on full choke like it's not getting enough fuel but it just died and wasn't able to do it again. I would also like to know where the mixture and the idle screw should exactly be set. Spark plugs and coil are newer from last year and the plugs even seem wet..and the intake even has a little fuel in it. Compressions are 118 and 120..
Any answers you guys got would be great!
Thanks
-Bri
 

·
Registered
Joined
·
187 Posts
I put a new coil on my sled last year and near the end of the season after the sled warmed up it just died, wait a few mins. and it started and ran until it got hot agian. I replaced the coil and knock on wood it has run perfect since. Just a thought!!!??
 

·
Registered
Joined
·
2,273 Posts
hmm. Fuel pump maybe?? When you say fuel pressure is okay, do you mean the pump is working?

Oh and that must be pre mix right?? Maybe its to rich?
 

·
Registered
Joined
·
553 Posts
when you did the compression test did it hold the compression for a little while? Or did it drop right away? And also was the test done at cold or warmed up temp? You should do it at warmed up temp. The reason I ask all of this is Im wondering if you have a bad crank seal.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
Compression was done cold and i'll have to do it again after i take the schrader valve out to see if it leaks down. When it runs off ether fuel flow is good and lots of vacuum at the throttle bore at the air cleaner end. And vacuum pulses are strong to the fuel pump. Pump just dribbles while cranking..good flow while running.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
Gas tank was emptyed and cleaned..mixed with fresh 89 octane and 50:1..pint per 6 gallons..fuel flow to pump is perfect..
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
well this thing has a cracked intake that was welded and all new gaskets and everything and if u even spray it down with ether in the area of the whole intake it does nothing so it's sealed. But with setting the air mixture to 1.5 turns it will start on ether and run for a long time if i pump the throttle rapidly and keep it about 3 grand and won't even come close to idle. Now can anyone explain how piston port works..reeds make sense to me but how does the fuel mixture reach the top of the piston if the port is below the rings?? And can i do a leak down by taking the schrader valve out of the gauge and hook it up to a compressor...but where do i put the piston to seal everthing to look or listen for a leak??
Thanks a million everyone..this dinosaur is driving me nuts..i love my 03 polaris!!
 
1 - 7 of 7 Posts
Top